Сокращения

БК – быстрая клавиша (доступа к товару)

ВБК – виртуальная быстрая клавиша (доступа к товару)

Прайсчер - инфокиоск

ШК – штрихкод

RunBot - RunBotService

Store – RunStore(он же RunFront)


Введение

Что такое RunBotService (RunBot)? Если коротко, то это система управления сервисами (плагинами) системы Run2010. На самом деле это даже не одна программа, а несколько. В первую очередь это непосредственно сам сервис RunBot, визуальный инструмент управления ServiceAdmin и подмножество плагинов. Плагин - это любой сервис, который имеет возможность работать под управлением RunBot. Плагины могут заниматься передачей файлов по ftp или email, автообновлением, прогрузкой весового и кассового оборудования магазина, обеспечением работы прайсчекеров и так далее.

Так же, RunBot, работая как web-сервер позволяет просматривать в браузере подробную информацию по работе некоторых плагинов и формировать RSS-рассылки.

tipbulb RunBotService

q Установка

q Структура каталога

q Настройка

q Web-сервер

ServiceAdmin

q Установка

q Настройка

q Подключение сервиса RunBot

q Работа с плагинами

Плагины

q Работа с кассами

q Работа с весами

q Работа с инфокиосками


Navigation: »No topics above this level«

Return to chapter overview

RunBotService


Установка RunBotService

Компьютер для установки RunBot в подразделении необходимо выбирать с учетом того, что сервис должен работать постоянно, машина не должна быть подвержена внезапным перезагрузкам и отключениям. Допускается установка RunBot на несколько машин в одном подразделении, однако желательно все же этого не делать, чтобы не запутаться потом самим.

Список изменений версии находится в файле ChangeList.html который выкладывается рядом с инсталлятором.

Установка осуществляется с помощью дистрибутива с названием RunBotService.x.xx.x.x.msi, где x - номер версии.

После выбора местоположения каталога с программой (по умолчанию C:\RR2010\RunBotService\) необходимо задать учетную запись, под которой будет запускаться сервис, обязательно обладающая правами администратора.

После установки, будет предпринята попытка запустить сервис. Если указанная учетная запись не обладала необходимыми правами, будет показано соответствующее предупреждение.

В дальнейшем, вы всегда можете найти этот сервис в надстройке "Службы" операционной системы, запустив из консоли "services.msc" или из меню: Пуск>Панель управления>Администрирование>services. Служба называется "Сервис заданий RunBotService". Если при установке была задана неверная учетная запись - тут ее можно изменить, и вручную запустить сервис.


Структура каталога

В папке с программой находятся следующие подпапки:

Logs | В этой папке находятся логи RunBot отдельно за каждый день в файлы c маской event_YYYY-MM-DD.log. Ошибки логируются дополнительно в файлы error_YYYY-MM-DD.log.
Plugins | Тут будут размещены установленные плагины, каждый в своей подпапке. Можно переопределить в настройках. В случае если один плагин устанавливаться несколько раз, к названию папки будет добавлен цифровой суффикс.
Updates | Каталог для обновлений.
WebServerRoot | Тут размещены файлы веб-сервера. Можно переопределить в настройках.
x64 | Библиотеки для работы с базой данных sqlite
x86 | Библиотеки для работы с базой данных sqlite
Repository | В этой папке необходимо размещать новые плагины для установки (как эталоны). Можно переопределить в настройках.

Так же в этой папке нас интересуют следующие файлы:

ChangeList.html | Список изменений для установленной версии RunBot
Config.sqlite | База данных содержащая информацию об установленных плагинах.
History.sqlite | База данных с информацией о результатах работы некоторых плагинов для отображения ее в web
Rss.sqlite | База данных rss-рассылок.
RunBotService.exe | Исполняемый файл сервиса.
RunBotService.exe.config | Файл конфигурации сервиса. Подробнее см. ниже, в настройках RunBotService.
Update.sqlite | База данных обновлений.


Настройка RunBotService

Настройка сервиса осуществляется с помощью файла RunBotService.exe.config находящимся в каталоге с программой. Файл представляет из себя обычный xml-документ. Необходимые для пользователя настройки подписаны комментариями. Все настройки находятся в секции <configuration>

Название настройки | Описание | Значение по умолчанию
Секция <configSections> (Не подлежит изменениям)
Секция <log4net> (Настройки системы логирования)
<root><level value="" /> | Главный параметр логирования, отвечает за уровень записи в лог файл. Уровень детализации журнала лога. Самая детальная - "TRACE", самая минималистичная - "FATAL". В повседневной работе достаточно уровня "INFO", для разбора каких либо ошибок, желательно иметь журнал с уровнем "TRACE". Варианты: FATAL ERROR WARN INFO DEBUG TRACE | <root><level value="INFO" />
Остальные настройки | См. описание конфигурации log4net в интернете. Но без крайней необходимости менять конфигурацию не стоит! |
Секция <startup> (Не подлежит изменениям)
Секция <applicationSettings> (Настройки приложения)
HeartBeat | Частота опроса плагинов на предмет выполнения действий по расписанию | 00:00:10
WaitTimeoutInSec | Максимальное время ожидания остановки сервиса в секундах | 20
PluginsDir | Каталог, в котором будут размещаться рабочие плагины и их локальные данные. | PluginsDir
RepositoryDir | Каталог с репозиторием плагинов. Сюда необходимо будет помещать плагины для установки. | RepositoryDir
SqliteTimeout | Таймаут для запросов к базе SQLite | 00:01:00
HostIp | IP, на котором следует работать данному сервису. Необходимо указать адрес в локальной сети подразделения (например 192.168.0.200) | 127.0.0.1
WebsiteRootDir | Каталог в котором размещается web-сервер | WebServerRoot
WebsitePort | Порт на котором работает web-сервер | 8081
Секция <system.web> (Не подлежит изменениям)
Секция <system.serviceModel>
<system.serviceModel> <services> <service name="RunBot.Server.RunBotService"> <endpoint..... /> | Адрес сервиса. Необходим для подключения к сервису через ServiceAdmin. Необходимо поменять IP-адрес, и по необходимости - порт. | address="net.tcp://localhost:8100/Run-Retail/RunBotService"

error

После изменений в конфигурационном файле, сервис необходимо перезапустить!


ServiceAdmin

ServiceAdmin - это визуальный инструмент управления всеми плагинами RunBotService.


Установка

ServiceAdmin распространяется без инсталлятора, в виде исполняемого файла ServiceAdmin.exe, который вы можете запускать с любого компьютера сети, из любой папки или флэшки.


Настройка ServiceAdmin

Настройка самой программы не требуется, в окне "настройки", открывающимся по нажатии на одноименную кнопку в верхнем правом углу окна программы, вы можете изменить цвет окна и размер шрифтов.


Подключение сервиса RunBot

При открытии программы мы увидим следующее окно:

Первое, что надо сделать, перейти на вкладку "Подключение сервисов"

В строке подключения поменять адрес сервера, где установлен RunBotService (и порт, если менялся) и нажать на кнопку с плюсиком. После чего в список сервисов будет добавлена новая запись. По необходимости вы можете добавлять сколько угодно сервисов RunBotService в этот список.

Если сервис запущен по указанному адресу - появится номер версии этого сервиса. Вы всегда можете обновить эту информацию, нажав на кнопку (3) в строке сервиса. Если вы ошиблись или сервис поменял адрес - удалите строку с помощью кнопки (2).

Для управления сервисом нажмите кнопку (1).


Работа с плагинами

Установка плагина.

Для работы с плагинами требуется установленное соединение с сервисом RunBotService. После этого можно перейти на вкладку "Плагины"(1) , а затем - в "Репозиторий"(2)

В этом окне будут показаны все доступные для установки плагины. Данные по ним будут получены из папки Repository (по умолчанию).

Для того что бы плагин появился в списке доступных (4) - выложите сам плагин (файл с расширением "dll") и информацию по нему (файл с расширением "info") в эту папку.

После того как все необходимые плагины будут выложены в репозиторий - обновите список плагинов в ServiceAdmin кнопкой (5).

Все плагины разделяются по группам, для удобства фильтрации в интерфейсе. Выбирая ту или иную группу в списке (3) можно отфильтровать список плагинов (4).

Для установки плагина в RunBot требуется нажать кнопку "Установить"(6). Допускается установка нескольких одинаковых плагинов (с различными настройками их работы). После установки, в столбце "Количество установок" измениться значение. Установленный плагин будет установлен в отдельную подпапку каталога "Plugins".

Настройка плагина.

Перейдите на вкладку "Установленные" (7), затем выделите в списке интересующий плагин, и откройте его настройки (8).

В панели справа будут показаны настройки плагина. Для каждого плагина эти настройки будут отличаться, однако блок "Конфигурация сервера" будет в каждом плагине. В нем, в первую очередь, нас интересует параметр "address", именно эту строку, в дальнейшем, надо будет указывать в качестве адреса плагина в программах системы Run. В случае использования 2х и более одинаковых плагинов - в адресе необходимо будет изменить порт (на любой незанятый).

Для внесения изменений, нажмите кнопку "Редактировать (9), а после правок - "Сохранить". Данные настройки находятся в файле "*.config" в папке рабочего плагина.

Запуск и остановка плагина

После установки и настройки плагин находится в не запущенном состоянии. Для запуска нажмите соответствующую кнопку (10), после чего рядом с названием плагина появится надпись "Работает".

Для остановки работающего плагина - кнопку "Выкл"(11). Так же, здесь вы сможете удалить не используемый плагин кнопкой "Удалить"(12) или перейти на вкладку настроек (13). Функционал остальных кнопок - в процессе разработки.

После успешного запуска плагина, с ним можно работать.


Плагины

tipbulb Кассовое ПО

· Плагин RunPosServer

Весовое оборудование

· Общая информация

· Плагин Aclas

· Плагин AclasSensor

· Плагин Bizerba

· Плагин Cas

· Плагин DIGI

· Плагин Shtrih

· Плагин Metler Toledo

Инфокиоски

· Плагин ShuttleSg15

ТСД

Плагин Mobile 2015


Оборудование

Группа плагинов, которые отвечают за взаимодействие с кассами, весовым оборудованием и т.д.


Navigation: Плагины > Оборудование >

Return to chapter overview

Кассы


Плагин RunPosServer

Назначение

Плагин обеспечивает коммутацию с кассами RunPos (win и unix). Обеспечивает их обслуживание, обеспечение данными, а так же получение и интерпретацию кассовых данных.

Обмен информации осуществляется в трех режимах:

·Широковещательный запрос используется при запуске/остановке плагина и кассы RunPos - с его помощью кассы и плагины узнают друг о друге.

·Wcf-сообщения используются для общения между плагином и кассой в обе стороны.

·Файловый tcp- сервер обеспечивает передачу файлов, например справочника товаров или кассовый отчет продаж.

Например, при запуске кассы, она посылает широковещательное сообщение - "я тут". RunPosServer видит это сообщение, и регистрирует кассу у себя, а так же отвечает кассе "я понял". Далее, например для прогрузки прайса плагин отсылает wcf-сообщение зарегистрированной кассе - "у меня есть для тебя новый прайс-лист, забрать файл можешь с такого файлового сервера". Касса подключается к указанному tcp-серверу, скачивает файл и уведомляет RunPosServer о том, что прайс получен.

Необходимое предустановленное ПО.

Для полноценной работы плагина требуется установленная база данных Mongo. Скачать последнюю версию под вашу операционную систему вы можете отсюда: http://www.mongodb.com/download-center. В базе Mongo сохраняется резервная база чеков, а так же отложенные чеки(в т. ч. QBuster). Наличие БД Mongo не обязательно, но в случае её отсутствия вышеперечисленные функции работать не будут.

Настройка плагина.

Значение параметров по умолчанию плагина и кассы соответствуют друг другу, и при установке как есть - все должно работать без дополнительной настройки (необходимо только указать верные IP адреса).

Название параметра | Описание | Значение по умолчанию
Кассовый сервер
IP адрес сервера | Адрес компьютера, где установлен плагин. Необходимо указывать, потому что не всегда удается понять автоматически с какого IP нужно работать. | 127.0.0.1
Конфигурация сервера | В параметре "address" узла "endpoint" этого блока указывается адрес и порт, который необходимо будет указать программе RunStore | address="net.tcp://localhost:8756/run-retail/RunPosService/Transport/"
Конфигурация сервера (со стороны касс) | Блок не нуждается в изменениях на данный момент. |
Файловый сервер
Порт | Какой порт со стороны плагина будет открываться для передачи файлов на кассы | 9999
Время жизни | Через сколько времени файлы для передачи нескольким кассам будут удалены с сервера. | 00:10
Мультикастинг
Ip адрес мультикаст группы | Адрес мультикаст группы. Не надо менять, если вы точно не уверены. Рядом с полем настойки есть две кнопки "Скопировать пример заполнения настроек в буфер обмена" и "Открыть пример заполнения настроек в блокноте", которые показывают как должен выглядеть блок настроек широковещательных сообщений на кассе. | 239.0.0.222
Порт сервера | Порт, с которого отправляются широковещательные запросы кассам. | 1945
Порт клиента | Порт, с которого ожидаются входящие сообщения от касс. | 1941
Настройка логирования
Уровень логирования | Уровень детализации журнала лога. Самая детальная - "трассировка", самая минималистичная - "фатальные ошибки". В повседневной работе достаточно уровня "Информация", для разбора каких либо ошибок, желательно иметь журнал с уровнем "трассировка". | Информация
Создавать или нет файлы с данными обмена с кассами | Если Да, то в папке плагина будет создан каталог DEBUG, и все файлы отправленные или полученные с касс будут сохраняться в виде xml-файлов. | Нет
Разное
Выводить настройки, совпадающие со значениями по-умолчанию | Пока не используется |
Максимальное количество параллельных задач | Рекомендуется ставить значение, равное количеству ядер процессора или незначительно превышающее это количество | 1
Mongo Database
Ip адрес mongo сервера | Адрес сервера Mongo | localhost
Порт | Порт сервера Mongo | 27017
Название базы данных | Название базы данных, будет создана, если не существует. | runpos
Название коллекции отчетов | Название коллекции отчетов, будет создана, если не существует. | rep

Настройки RunPos

Для того, чтобы касса могла работать с плагином необходимо, в файле config.ini или local.ini (находятся в папке с RunPOS под ОС Windows или /etc/runpos/ при использовании ОС Linux) добавить (если её нет) или отредактировать секцию:

[NETWORK]

MulticastAddress = 239.0.0.222

MulticastListenPort = 1941

MulticastOutPort = 1945

LocalServerAddress = 127.0.0.1 # поменять на IP адрес текущей кассы, если она установлена не на одном компьютере с RunBot'ом

LocalServerPort = 9997

После сохранения файла необходимо перегрузить кассу.

Настройка RunStore

В модуле магазина необходимо добавить кассовый сервер (Управление - Настройки Кассовых Серверов).

Нажмите на кнопку "Добавить". Выберите "Для кассы RunRetail(WCF)" и нажмите "Ок".

В появившимся окне измените описание сервера (по желанию), а в поле "конфигурация сервера", в строке

<endpoint address="net.tcp://127.0.0.1:8756/run-retail/RunPosService/Transport/",

поменяйте 127.0.0.1 на реальный IP адрес на котором работает RunBot и RunPosService, а так же измените порт по необходимости (строка должна совпадать с той, что указана в параметре "address" узла "endpoint" поля "конфигурация сервера" плагина RunPosService. По умолчанию - 8756). Для проверки правильности необходимо нажать кнопку "Проверить",и удостовериться что связь установлена.

Добавить новую кассу(ы) (Управление - Настройки касс - Добавить

В списке выбрать тип кассы - "Касса RunRetail POS(WCF)" и нажмите кнопку "След". Теперь выберите созданный ранее кассовый сервер и нажмите кнопку "След".

В следующем окне мастера надо заполнить реквизиты кассы, а так же проверить соединение с плагином и с кассой, после чего добавление кассы завершается.

По умолчанию, на кассы НЕ будут выгружаться пароли кассиров, так как они заданы только для старой кассы. Надо зайти в (Персонал - Кассиры - Изменить. Установить галки в строке "Касса RunRetail POS (WCF)", распечатать бэйджи и прогрузить данные ВСЕХ операторов на кассы, стандартным способом, кнопка "В кассы" .)


Весы

Назначение

Плагины обеспечивают выгрузку информации на весовое оборудование - весы, упаковщики, и т.д. Один плагин может работать с несколькими модификациями устройств одного типа (производителя).

Данное руководство содержит необходимый и достаточный минимум для настройки и запуска в работу весового оборудования магазина. Вы можете не соблюдать или соблюдать не полностью данные тут рекомендации, но при возникновении проблем с устройствами, перед подачей заявки в OTRS, проверьте пожалуйста – установка рекомендуемых настроек (по умолчанию) не спасет ситуацию?

error

Для того, чтобы весы прогружались с помощью плагинов - в rrSettings изменить настройку "7013 Настройки весов для сервиса": на "RunBot" ! Иначе система будет считать, что работает с DeviceService

Настройка плагина.

Все плагины весов имеют одинаковые настройки (со стороны ServiceAdmin)

Название параметра

Описание

Значение по умолчанию

Сервер весов

Конфигурация сервера

В параметре "address" узла "endpoint" этого блока указывается адрес и порт, который необходимо будет указать программе RunStore в качестве Uri плагина.

зависит от плагина. Например: address="net.tcp://localhost:8059/Run-Retail/ScaleService/Aclas/"

Хранение данных

Где плагин хранит информацию о текущей и завершенных загрузках.

·"В памяти" - работает незначительно быстрее, но информация о завершенных загрузках не сохраняется, и посмотреть ее через запрос к web-серверу не удастся.

·"В базе SQLite" - сохраняется подробная информация о прошедших загрузках. Получить ее можно через web-сервер runbot.

В базе SQLite

Удалять историю

Имеет смысл, если настройка "Хранение данных" = "В базе SQLite". Указывает, через сколько времени удалять информацию об успешных загрузках.

24 часа.

Настройка логирования

Уровень логирования

Уровень детализации журнала лога. Самая детальная - "трассировка", самая минималистичная - "фатальные ошибки". В повседневной работе достаточно уровня "Информация", для разбора каких либо ошибок, желательно иметь журнал с уровнем "трассировка".

Информация

Добавление весов в RunStore

Для того, что бы добавить новые весы, нажмите в меню RunStore кнопку "Управление", а затем "Настройки весов". В открывшимся окне нажмите кнопку "Добавить". Выберите интересующую модификацию весов и нажмите "Ок".

Настройка весов

Окно настроек разделено на две части. В верхней перечислены настройки весов которые задаются для любых типов весов. В нижней части настройки зависят от подключенного плагина.

Порядок действий такой:

1.Заполняется верхняя часть настроек (см таблицу ниже)

2.Сохраняем настройки

3.Нажимаем "Проверить"

4.В нижней части нажимаем "Редактировать"

5.Редактируем нижнюю часть настроек (см. таблицы в описании конкретных плагинов)

6.Закрываем с сохранением.

Общие для всех весов настройки (верхняя часть)

Название параметра | Описание | Значение по умолчанию
Uri плагина. | Уникальный адрес плагина который задавался в настройках плагина (см. предыдущую таблицу). Например "net.tcp://localhost:8059/Run-Retail/ScaleService/Aclas/" |
Использовать весы | Временное отключение весов | Да
Весовые товары | Разрешение на привязку весовых товаров | Да
Штучные товары | Разрешение на привязку штучных товаров. Для штучного товара весы будут формировать ШК на «один кг» товара, что кассой воспринимается как одна штука. | Нет
Выгружать в PLU | Выбор сущности, которая будет выгружаться на весы в качестве уникального номера Варианты: ·Код товара ·PLU ·Быстрая кнопка | Код товара
№ весов | Номер весов для отображения в интерфейсе пользователя | 0
Название весов | Название весов для отображения в интерфейсе пользователя |
Весы-эталон для товаров | При указании в этом поле существующих весов, достаточно привязать товары только к указанным весам, к текущим весам привязки товара будут браться с них. Настройки с эталона браться НЕ БУДУТ |
Отчет для печати кнопок | Шаблон отчета, который будет применяться для печати раскладки быстрых кнопок для клавиатуры весов, в том числе и клавиатур весов самообслуживания |


Плагин Aclas

Назначение

Плагин обеспечивает обмен информацией с весами Aclas.

Работа с весами осуществляется без ПО поставщика, однако для настройки эталонных весов, создания этикеток, проверки работы весов необходимо установить последнюю версию MControlSrvSetup. (можно самостоятельно выкачивать с ftp://ftpserver.etim.ru/Aclas/. На момент написания этих строк, последняя версия – McontrolSrvSetup.0.0.11.15). ВАЖНЫЙ момент: при установке этого ПО, в окне выбора компонентов НЕОБХОДИМО снять галочку "сервер загрузки". Если установка была вместе с этим сервером – найдите в службах Windows "Aclas Scale Server" и отключите ее (службу), установив "тип запуска = отключена")

Размещение

\Services\RunBot.Plugins\Aclas.x.x.x.x.7z

Настройка оборудования

Установка IP:

Нажмите кнопку "Прогр" и удерживайте её в течение секунды. На дисплее отобразится первый пункт меню. Используя клавиши "←" и "→" найдите настройку "21 – IP адрес". Для входа в текущий пункт меню, нажмите Ввод. По окончании ввода данных нажмите Ввод.

Пропингуйте весы с компьютера.

Настройки RunStore

Название настройки | Описание | Значение по умолчанию
Соединение TCP
IP весов | IP весов | 127.0.0.1
Время ожидания ответа от весов | Время в миллисекундах ожидания получения ответа от весов на каждую команду. | 1000
UDP порт весов | Порт открытый на весах для обмена. | 5001
Локальный UDP порт сервера | Локальный UDP порт сервера | 62771
Весы Aclas
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Бегущая строка | Текст, который будет прокручиваться на дисплее весов. По умолчанию – пустая строка, которая, однако, будет прогружена (затрет существующую). Максимальная длина – 22 символа (лишнее будет отсечено) | ""
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Формат Штрихкода | Номер структуры ШК в памяти весов. По умолчанию стоит "Автоопределение", что означает, что плагин сам выберет необходимый формат, исходя из настройки "Максимальная длина кода" Однако имеется возможность выбрать пользовательский формат 99. Без ознакомления с документацией на весы менять не рекомендуется. | Автоопределение
Используемый формат этикетки | Номер шаблона этикетки, по умолчанию устанавливающийся каждому товару. Он может быть переопределен в списке привязанных товаров. Должен быть в диапазоне 0-7. В редакторе этикеток они перечислены в таком порядке: 0 – А0 1 – А1 2 – B0 3 – B1 4 – C0 5 – C1 6 – D0 7 – D1 |

Настройка сетевого соединения для нескольких весов.

Данные весы работают по протоколу UDP, а не TCP, как все остальные (кроме штрих-принт). В связи с этим в настройках со стороны RunStore появилась настройка «Локальный UDP порт сервера». Следует понимать, что во время прогрузки одних весов Aclas, указанный порт будет занят, и если вы захотите использовать режим параллельной выгрузки – НЕОБХОДИМО для ВСЕХ весов давать РАЗНЫЕ номера портов СЕРВЕРА! Рекомендуем всегда в пределах одного магазина давать разные порты, даже если не планируется использовать параллельную выгрузку.


Плагин AclasSensor

Назначение

Плагин обеспечивает обмен информацией с весами Aclas c сенсорным экраном под управлением ОС Windows (R1)

Выгрузка данных осуществляется с помощью файла InScale.xml, который размещается в расшаренной папке Import на управляющем модуле весов (компьютере).

Размещение

\Services\RunBot.Plugins\AclasSensor.x.x.x.x.7z

Настройка оборудования

Настройка весов осуществляется по документации производителя.

Настройки RunStore

Настройки RunStore

Название настройки | Описание | Значение по умолчанию
Соединение TCP
Вариант загрузки файлов на весы | На ранних прошивках весов возможен вариант только через общедоступный каталог. Варианты: ·Через общий каталог ·Через FTP |
Ip адрес ftp-сервера весов | Реальный IP ftp-сервера на котором работают весы. Настройка имеет смысл, если выбран обмен через ftp-сервер | 127.0.0.1
Имя пользователя ftp | Имя пользователя ftp. Настройка имеет смысл, если выбран обмен через ftp-сервер | ftp
Пароль пользователя ftp | Пароль пользователя ftp. Настройка имеет смысл, если выбран обмен через ftp-сервер | ftpuser
Путь к папке импорта на весах | Настройка имеет смысл, если выбран обмен через общий каталог |
Весы Aclas с сенсорным экраном
Используемый формат этикетки | Номер шаблона этикетки, по умолчанию устанавливающийся каждому товару. Он может быть переопределен в списке привязанных товаров. Должен быть в диапазоне 0-7. В редакторе этикеток они перечислены в таком порядке: 0 – А0 1 – А1 2 – B0 3 – B1 4 – C0 5 – C1 6 – D0 7 – D1 | D0
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5
Формат Штрихкода | Номер структуры ШК в памяти весов. По умолчанию стоит "Автоопределение", что означает, что плагин сам выберет необходимый формат, исходя из настройки "Максимальная длина кода" Однако имеется возможность выбрать пользовательский формат 99. Без ознакомления с документацией на весы менять не рекомендуется. | Автоопределение
Разбиение строки на подстроки | Данные весы плохо работают с длинными строками в доп. текстах, поэтому желательно проставить переносы на стороне DS. Варианты: ·Не разбивать ·Разбивать по символам ·Разбивать по словам | Разбивать по символам
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Бегущая строка | Текст, который будет прокручиваться на дисплее весов. По умолчанию – пустая строка, которая, однако, будет прогружена (затрет существующую). Максимальная длина – 22 символа (лишнее будет отсечено) | ""
Максимальная длина строки сообщения | Если настройка "Разбиение строки на подстроки" не установлена в "не разбивать" то указанное тут количество символов будет применяться для расстановки переносов. | 58

Следует учесть то, что операция выгрузки этикеток и выгрузки товаров – две совершенно не связанных между собой операции, однако и та и другая формируют файл с одинаковым именем InScale.xml (это ограничение со стороны ПО весов). Это может привести к тому, что при быстрой, последовательной выгрузке обоих заданий возможно появление конфликтов – первая операция может просто пропасть, или вторая завершится ошибкой невозможности записи.


Плагин Bizerba

Назначение

Плагин обеспечивает обмен информацией с весами Bizerba. Поддерживаются весы серий BC II ,CS II , BS, KH.

Размещение

\Services\RunBot.Plugins\Bizerba.x.x.x.x.7z


Bizerba BC II

Настройка оборудования

1.Входим в режим программирования. Для этого служит клавиша <MOD>. На экране будет отображено приглашение: Pr___. Далее с помощью клавиатуры вводим номер группы настроек и жмем <Enter>. Для входа в выбранное меню – снова нажимаем<Enter>. Для выхода с текущего уровня меня на предыдущее можно нажать <Esc>. Для выхода из режима настроек можно повторно нажимать клавишу <MOD>

2.Если весы не новые – скидываем в настройки по умолчанию. Для этого входим в меню Pr606 Пуск в эксплуатацию

88<Enter> = Начать пуск в эксплуатацию:

90<Enter> = Стирание памяти и сохранение стандартных настроек

ВНИМАНИЕ! Выбор этого пункта приведёт к полному обнулению весов на заводские настройки.

Весы перезагружаются(boot-Cr).

Про нажатие <Enter> писать не буду далее, думаю смысл навигации уже понятен.

После сброса весы принимают стандартные настройки распределения памяти. Стоит их проверить и поменять

Pr606

01= Число ячеек PLU (00100-6000) – стоит ставить как можно больше

02= Число дополнительных текстов на одну ячейку PLU (0-4). В данный момент не используется поэтому ставим 0.

03= Число текстовых полей из программы BLD на одну ячейку PLU (0-10). В данный момент используется только одно дополнительное поле, поэтому ставим 1.

04= Число графических полей из программы BLD на одну ячейку PLU (0-3).В данный момент не используется.

05= Число дополнительных текстов (50-3000) стоит ставить как можно больше.

06= Число позиций (накопитель чеков, 50-1200) – в РФ не используется, ставить минимально возможное (50)

07= Набор параметров. Разрешение - (1) или запрещение - (0):

·- расчетные товары вкл (1-й разряд),

·- фиксированный вес (2-й разряд),

·- учёт НДС (3-й разряд),

·- тара % (4-й разряд).

В данный момент все они не используется, оставляем 0000.

Возможен вариант с 6-ю разрядами

·5й - печать этикетки вкл, ставим 1,

·6-й - включить режим форматирования срока годности, ставим 1.

08= Число знаков после запятой в цене (оставляем 4 по умолчанию)

88= Начать пуск в эксплуатацию (на экране - оставшийся объем свободной памяти в байтах):

Вводим 81, затем <Enter>= Стирание памяти и сохранение заданных настроек.

ВНИМАНИЕ! Выбор этого пункта приведёт к полному обнулению весов с настройками распределения памяти, введёнными в предыдущих пунктах меню606 включая конфигурацию памяти, информацию о товаре и т.п.

Весы перезагружаются (boot-Cr).

3.Настраиваем IP адрес. Pr600:

01= DHCP

0= не использовать DHCP, использовать фиксированный IP-адрес из подменю 03

1= использовать DHCP для получения адреса от DHCP-сервера

03= IP-адрес (12-значнное число без точек, напр. 172.17.168.10 вводить как 172017168010)

04= Подсеть: маска подсети (255.255.192.000 вводить как 255255192000)

05= Шлюз: адрес роутера (172.17.129.1 вводить как 172017129001)

06= DNS1: адрес сервера доменных имен 1

07= DNS2: адрес сервера доменных имен 2

Обычно необходимо и достаточно (для примера):
Pr600/01 =0
Pr600/03 =192168000234

4.Выгружаем этикетку из программы Bld.Brain. Номер этикетки может быть любой. См. ниже пункт настроек весов в Store. Выгрузка этикетки должна происходить именно в этом месте, следующие пункты зависят от этого действия. Прогрузка форматов этикеток из Store не осуществляется!

5. Осуществляем донастройку весов вручную (к сожалению, передать настройки из Store не удается в связи с невозможностью найти документацию)
Pr555/
01 = 0 Тип используемой этикетки – из Bld

02 = ? номер этикетки из BLD (1, ну или любая другая – какую создали в BLD )

05= ? печатать дату упаковки (1я цифра) и хранения (2я цифра): 1 – печатать, 0 – нет (например 11)

06 = 10 печатать ШК товара (1я цифра)и ШК суммы (2я цифра): 1 – печатать, 0 – нет

11 =? номер логотипа для колонтитула если используется

Pr535/

01= 2 C десятичной клавиатуры только ввод номера PLU. Ввод базовой цены с десятичной клавиатуры запрещен.

03 = 2 Клавиши прямого вызова PLU служат для вызова записей отдельных товаров.

Pr516 /
01 = 1 Если надо включить бегущую строку загруженную из Store. 0 – если не надо.

Если необходим режим фасовки, то переключаем режим:
Pr510/

01 = 05 (вернуться в обычный режим – 01)

Обращаю ваше внимание на то, что устанавливать время и шаблоны ШК не имеет смысла, это сделает плагин при первой же выгрузке из RunStore.

Настройки RunStore

Название настройки | Описание | Значение по умолчанию
Соединение TCP
Ip адрес весов | IP весов | 127.0.0.1
Порт весов | Порт со стороны весов | 5001
Время ожидания ответа от весов | Время в миллисекундах ожидания получения ответа от весов на каждую команду. | 1000
Весы Bizerba
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Синхронизировать время | Синхронизировать или нет время и дату при каждой прогрузке весов | Да
Игнорировать товары без установленной БК | Если выбрано "Да", то товар с неустановленной быстрой клавишей будет проигнорирован при прогрузке. | Да
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5
Бегущая строка | Бегущая строка для табло покупателя. |
Название магазина | Текст для шапки(подвала) этикетки |
Количество PLU | Максимальное количество PLU(товаров), которые могут быть прогружены на весы | 2000
Количество текстов | Максимальное количество доп. текстов, которые могут быть прогружены на весы | 2000
Количество быстрых клавиш | Максимальное количество быстрых клавиш, которые могут быть прогружены на весы. | 256
Где показывать срок годности | Где выводить срок годности на этикетке. ·На стандартном месте, в отдельном поле. ·В теле доп. сообщения ·Под названием товара | Под названием товара
Надпись печатающаяся перед сроком годности | Надпись печатающаяся перед сроком годности |

Весы настроены.

При выгрузке товаров на весы, плагин сперва синхронизирует время (в зависимости от настройки), затем чистит весы (в зависимости от настройки), затем выгружается структура ШК формируемая динамически, название магазина. После этого, в цикле выгружается PLU/сообщение/быстрая клавиша.

Если в процессе загрузки количество доп.сообщений превысит значение, указанное в настройке «Максимальное количество текстов» то цикл будет продолжен, но доп. сообщения выгружаться НЕ БУДУТ. В логе плагина будет выведено соответствующее предупреждение.

Если в процессе загрузки количество товаров превысит значение, указанное в настройке «Максимальное количество PLU» то цикл будет остановлен, оставшиеся товары НЕ БУДУТ загружены. В логе будет выведено соответствующее предупреждение.


Bizerba BS

Настройка оборудования

Вход режим настройки осуществляется нажатием клавиши <MOD>. Появится предложение ввести пароль. Вводим его, если есть и жмем <Enter>

Попадаем в меню, по которому можно перемещаться с помощью клавиш <↑> и <↓>. Вход в подменю - <Enter>, выход из него - <ESC>. Также для входа в подменю можно нажимать соответствующую цифру.

Настройки бывают следующих видов:

·Число. Приглашение выглядит как "_ _ _ 1" Для изменения достаточно набрать необходимое значение и нажать стрелочку или <Enter> для перехода к следующему пункту.

·Выбор из списка. Приглашение выглядит как "[]". При нажатии <Enter> попадаем внутрь списка, элементы его будут отображаться в верхней части дисплее. Их изменение возможно с помощью клавиш <↑> и <↓>. При этом приглашение будет иметь вид: "[ . . . . ]".

·Логическое (да/нет). Выбрать можно только из двух вариантов 0 (нет) и 1 (да). Приглашение при этом выглядит как "[ 0 ]" или "[ 1 ]".

Нажатие на <MOD> равносильно отмене изменений и выходу в режим продаж.

Сброс RAM

Полный сброс весов (если имеется потребность) делается следующим образом – выбираем меню 6) Ввод в эксплуат. –> 6) Обнулить RAM - > Запустить = Да (стрелочками). Весы уходят в задумчивость, после чего открывается меню ввода в эксплуатацию. Тут, в первом пункте меню можно настроить необходимые параметры весов (см. ниже), а можно оставить это на потом. Для продолжения работы выбираем 2) Ввод в эксплуат. - >3)Измен. ввод в эксп.

Изменяем или просто смотрим и запоминаем:

1)Данные PLU ->1) PLU->
Количество PLU – это понадобится для настройки Store.

Количество текст. полей стоит поставить = 1 (это не количество текстов вообще, а сколько текстов выделять на одно PLU)
Остальное по желанию, т.е. если не уверены – не трогаем.
Возвращаемся и идем в 2) Ввод в эксплуат. - >3)Измен. ввод в эксп. -> 4)Тексты / этикетки ->1)Общие тексты ->

К-во общих текстов = указываем, как захочется, но не менее чем вышеуказанное количество PLU, иначе могут быть накладки в дальнейшей работе.

Средняя длина текста = тоже рекомендую до реального значения увеличить.

4)Тексты / этикетки ->3)Этикетки ->

Количество этикеток = Сколько хотите, но если будет 0 - Bld.Brain не сможет загрузить ни одной этикетки, и пользоваться можно будет только встроенными форматами.

Возвращаемся к самому верху
2) Ввод в эксплуат. ->4)Запуст. ввод в эксп. ->Запустить = Да(стрелочками) -> Никакие данные (стрелочками). Финальное подтверждение Загруз. Клав. – жмем <Enter>. Ждем.

Первоначальные настройки на весах

Далее буду писать все меню в сокращенной форме как указатель номеров этих самых меню.

Самое главное – настройка IP адреса. Меню 5-3-8-3-3. Тут заполняем параметр IP адрес и маску подсети. Остальное обычно не нужно.

Проверить тип декодирования входящих данных. В ранних версиях весов такой настройки нет.

5)Конфигурация весов->3)Изменить конфигурацию->8)Интерфейсы->3)Сеть->2)Протоколы->1)Подключение сервера.

Кодировка должна быть установлена в Biz_KY (она же – CIS). Если стоит что-то иное – будут крякозяблы вместо названий товаров и текстов.

Далее выгружаем этикетку из программы Bld.Brain. Номер этикетки может быть любой. См. ниже пункт настроек весов в Store. Выгрузка этикетки должна происходить именно в этом месте, следующие пункты зависят от этого действия. Прогрузка форматов этикеток из Store не осуществляется!

Настраиваем этикетку (минимально необходимые настройки)
5-3-2-2-4

Режим работы = этикетка

Распечатать штрихкод = Да

Тип этикетки = Своб.прогр.этик.

N = выберите одну из тех, что прогрузили из Bld.Brain.

Своб.прог.этикетка ->1)Упоряд.текст.полей->Этикетка PLU = Из PLU

Текст на каждый PLU ->Распеч.общ.текст = Да

Включение бегущей строки:

5-3-6-5
Бегущая строка = 1 (под номером 1 выгружается текст из плагина)

Если на весы в качестве номера PLU выгружаются коды товаров из Store, надо изменить ограничение на ввод символов номера PLU (по умолчанию 3).

5-3-6-3

N PLU осн.настройки -> знаки ввода PLU = 6 (или 5, если нету длинных кодов товара)

Время и шаблоны ШК настраивать не нужно, все придет из плагина.

Настройка RunStore.

Все настройки полностью аналогичны весам Bizerba BC II.


Bizerba CS II

Данные весы настраиваются точно так же, как и весы серии BS. Единственное, значимое для настройки их отличие – размещение быстрых клавиш на клавиатурах самообслуживания. Для привязки БК на верхней клавиатуре надо использовать номера от 151 до 246, на средней от 55 до 150, нижняя стандартна для большинства весов серий CS и BS – от 1 до 53 (54я – не используется).

Для удобства покупателей рекомендуется переназначать эти кнопки с помощью ВБК.


Bizerba KH (На базе PosReady 7)

Настройка оборудования

Вход в режим обслуживания (из режима самообслуживания) осуществляется нажатием и удерживанием в течение пяти секунд на сумме товара (справа вверху экрана).

Для попадания в меню настроек необходимо нажать на кнопку

Первичная настройка весов.

Если весы не находятся в режиме самообслуживания, то в настройки можно попасть нажав кнопки

Далее набрать пароль (если установлен) и нажать

N.B. Если вы хотите выйти из меню настроек с сохранением информации – нажимайте кнопку [image] несколько раз до выхода из меню. Если нажать на кнопку «Выйти из меню» то данные не будут сохранены в некоторых случаях.

Установить IP адрес

5)Конфигурация весов->3)Изменить конфигурацию->8)Интерфейсы->3)Сеть->3)Ethernet

Проверить тип декодирования входящих данных.

5)Конфигурация весов->3)Изменить конфигурацию->8)Интерфейсы->3)Сеть->2)Протоколы->1)Подключение сервера.

Должно быть установлено UTF8. Если стоит что-то иное – будут крякозяблы вместо названий товаров.

Выходим из настроек весов. Со стороны компьютера проверяем связь и выгружаем этикетку из BLD. Также необходимо из Store выгрузить товары и раскладку экранов (см. ниже настройки Store)

После этого заходим в настройку весов снова и продолжаем.

Если будут работать в режиме самообслуживания (для чего они собственно и нужны) то проверяем режим работы:

5)Конфигурация весов->3)Изменить конфигурацию->6)Настройки весов->1)Режимы обслуживания

Обслуживание несколькими продавцами – Нет
Непрерывное обслуживание – Нет

Режим обслуживания: N покуп./продавца автомат
Вызов цены и запись – да

Фиксированная клавиша продавца = 1

5)Конфигурация весов->3)Изменить конфигурацию->6)Настройки весов->2)Режим работы. Должен стоять режим самообсл.

5)Конфигурация весов->3)Изменить конфигурацию->1)Клавиатура->2)Profiles

Приложение – должно быть выставлено в Самообслуживание

Вариант – выбор имени проекта из Store или RetailVision. В первом случае называться будет runretail во втором, как сами назовете.

Тут надо отменить, что сперва следует выгрузить тот проект которым будем пользоваться, а потом выбирать его имя из списка. Весы принимают проект экрана в тот режим, в котором они находятся в момент приема. Поэтому вначале меняем режим и приложение, а затем сохраняем настройки (выходя из них). Если режим менялся – весы надо перезапустить. После этого грузим товар из RunStore еще раз (или проект экрана из RetailVision). Он автоматически будет применен.

Теперь конфигурация этикетки.

5)Конфигурация весов->3)Изменить конфигурацию->2)Принтер->2)Принтер 1-> 4)Этикетка1

Режим работы = Этикетка.

Штрихкод печатается = Да

Тип этикетки = Своб.прогр.этик.

N = Выберете этикетку которую создали в BLD.

Выходим из настроек

Настройки RunStore

Название настройки | Описание | Значение по умолчанию
Соединение TCP
Ip адрес весов | IP весов | 127.0.0.1
Порт весов | Порт со стороны весов | 5001
Время ожидания ответа от весов | Время в миллисекундах ожидания получения ответа от весов на каждую команду. | 1000
Имя пользователя ftp | Имя пользователя ftp, обязательна для выгрузки экранов | bizuser
Пароль пользователя ftp | Пароль пользователя ftp, обязательна для выгрузки экранов | bizerba
Весы Bizerba
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Синхронизировать время | Синхронизировать или нет время и дату при каждой прогрузке весов | Да
Игнорировать товары без установленной БК | Если выбрано "Да", то товар с неустановленной быстрой клавишей будет проигнорирован при прогрузке. | Да
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5
Бегущая строка | Бегущая строка для табло покупателя. |
Название магазина | Текст для шапки(подвала) этикетки |
Количество PLU | Максимальное количество PLU(товаров), которые могут быть прогружены на весы | 2000
Количество текстов | Максимальное количество доп. текстов, которые могут быть прогружены на весы | 2000
Количество быстрых клавиш | Максимальное количество быстрых клавиш, которые могут быть прогружены на весы. | 256
Где показывать срок годности | Где выводить срок годности на этикетке. ·На стандартном месте, в отдельном поле. ·В теле доп. сообщения ·Под названием товара | Под названием товара
Надпись печатающаяся перед сроком годности | Надпись печатающаяся перед сроком годности |
Выгружать экраны | Создавать и выгружать экраны весов самообслуживания. Если поставить Нет, то можно использовать самостоятельно созданные экраны. | Да
Настройки экрана | Настройки форматирования и внешнего вида экрана в виде xml-документа. Описано ниже. | Очень большая строка, в табличку не влезет J

Настройки экрана весов

Настройка представляет собой стандартный XML документ. При нарушении стандартов его формирования, при загрузке товара на весы в лог файл будет записано предупреждение, а выгрузка произойдет с параметрами по умолчанию (полностью или частично).

Документ состоит из коневого узла XmlSettings отвечающего за общие настройки. В нем описаны несколько панелей (Panel) и логотип (ImageLayer). В каждой панели – клавиша (Key), а в ней – слои (TextLayer и PictureLayer)

Цвет в параметрах описывается или как десятичное, или как шестнадцатеричное число. В последнем случае оно должно начинаться с "0x", например 0xFFFFFF или #, например #FFFFFF

В строчных параметрах – не забывайте экранировать спецсимволы.

XmlSettings
XmlBackgroundColor | Цвет всех экранов
SourceForGoodText | Источник текста для товара выводимого на кнопках. Может быть 1 – из данных товара (ценник) или 2 – название привязанной к товару картинки.
CaptionForKeyForward | Подпись для кнопки, которая ведет к следующему экрану
CaptionForKeyBack | Подпись для кнопки, которая ведет к предыдущему экрану

Panel Область экрана предназначенная для вывода кнопок. При этом размер кнопок будет рассчитываться динамически, в зависимости от геометрических размеров панели.
name | Имя панели. Может принимать только три значения: PanelNavigation – кнопки ведущие к разным экранам по номерам товара (например "11-20") PanelNavigationQuick – кнопки вперед и назад PanelPlu – кнопки товаров.
IsHide | Следует ли спрятать данную панель. Варианты – true или false
X | Координата начала панели от левой стороны экрана (0..800)
Y | Координата начала панели от верхней части экрана. (200..600) Координаты задаются абсолютными значениями, поэтому для экранов весов этот параметр должен начинаться с 200 – именно столько занимает шапка с системными данными.
Width | Ширина панели (1..800)
Height | Высота панели (1..400)
ItemPerRow | Сколько кнопок будет в ряду
ItemPerColumn | Сколько кнопок будет в столбце
Spacing | Сколько пикселей отступать от края панели и между кнопками

Key Описывает границы кнопки и ее внешний вид.
name | Имя кнопки. В зависимости от панели может быть NavKey, NavQuickKey или PluKey.
FillTrasparenty | Параметр отвечающий за прозрачность фона. 0 – непрозрачно, 100 – полностью прозрачно.
FillColor | Цвет фона.
FillColorPressed | Цвет фона при нажатии.
LineWidth | Толщина линии вокруг элемента. Практика показывает, что больше чем 1 ставить не стоит.
LineColor | Цвет линии
LineColorPressed | Цвет линии при нажатии
IsLineTrasparent | Прозрачна ли линия. Варианты – true или false

TextLayer Надпись (текстовой слой в кнопке)
name | Имя слоя. NavKeyTextLayer – в кнопке навигации NavQuickKeyTextLayer – в кнопке вперед/назад PluKeyGoodNameTextLayer – название товара в кнопке PLU PluKeyGoodNumberTextLayer – номер товара в кнопке PLU
X | Относительная координата начала надписи от левой стороны кнопки.
Y | Относительная координата начала надписи от верхней части кнопки.
Width | Ширина - абсолютное значение. Если 0 – то используется вся ширина кнопки.
Height | Высота - абсолютное значение. Если 0 – то используется вся высота кнопки.
Xreverse | Сменить начало координаты X на противоположную. Т.е. если указано true, а x=10, то размеры элемента будут рассчитываться с отступом 10 пикселей от ПРАВОЙ части кнопки. Варианты – true или false
Yreverse | Сменить начало координаты Y на противоположную. Аналогично предыдущему параметру. Варианты – true или false
FillTrasparenty | Параметр отвечающий за прозрачность фона. 0 – непрозрачно, 100 – полностью прозрачно.
FillColor | Цвет фона.
FillColorPressed | Цвет фона при нажатии.
LineColor | Цвет линии
LineColorPressed | Цвет линии при нажатии
LineWidth | Толщина линии вокруг элемента. Практика показывает, что больше чем 1 ставить не стоит.
IsLineTrasparent | Прозрачна ли линия. Варианты – true или false
FontName | Шрифт для надписи. Используются только несколько шрифтом, посмотреть список можно в RetailVision. По умолчанию установлен "Arial"
FontSize | Размер шрифта
FontColor | Цвет шрифта
FontColorPressed | Цвет шрифта при нажатии. Используется только для кнопок навигации в нажатом состоянии.
HorizAlign | Горизонтальное выравнивание. 0 – Слева 1 – По центру 2 - Справа
VertAlign | Вертикальное выравнивание. 0 – Сверху 4 – По центру 8 - Внизу
MarginHoriz | Отступы справа и слева от текста.
MarginVert | Отступы сверху и снизу от текста.

PictureLayer Картинка (графический слой в кнопке)
name | PluKeyGoodImage – картинка товара (выгруженная из Store) PluKeyNumberImage – картинка-подложка под номер товара на кнопке. LogoClient – логотип магазина для размещения на каждом экране.
IsHide | Следует ли спрятать данную панель. Варианты – true или false
X | Относительная координата начала надписи от левой стороны кнопки.
Y | Относительная координата начала надписи от верхней части кнопки.
Width | Ширина - абсолютное значение. Если 0 – то используется вся ширина кнопки.
Height | Высота - абсолютное значение. Если 0 – то используется вся высота кнопки.
Xreverse | Сменить начало координаты X на противоположную. Т.е. если указано true, а x=10, то размеры элемента будут рассчитываться с отступом 10 пикселей от ПРАВОЙ части кнопки. Варианты – true или false
Yreverse | Сменить начало координаты Y на противоположную. Аналогично предыдущему параметру. Варианты – true или false
ZoomModeImage | Варианты преобразования геометрии изображения. 0 – вписать по границам 1 – вписать, соблюдая пропорции 2 – абсолютный размер.
PathToPicture | Полный путь (доступный с машины, на которой установлен плагин) до картинки наложенный поверх картинки товара в кнопке –подложка под короткий номер этого товара или логотипа магазина. Для товаров данный параметр будет игнорироваться.

Следует учитывать, что размеры слоев в кнопках указываются в абсолютных значениях, а сами размеры кнопок формируются динамически в зависимости от количества кнопок в панели.

Количество возможных кнопок на экранах рассчитывается как (Сколько кнопок товаров в ряду * Сколько кнопок товаров в столбце) * (Сколько навигационных кнопок в ряд * Сколько навигационных кнопок в столбце).

Т.е. для настроек по умолчанию 2*7*3*4 =168.

Так же, следует иметь в виду, что товар без привязанной картинки не появится на экране самообслуживания!

При выгрузке товаров на весы, плагин вначале синхронизирует время (в зависимости от настройки), затем чистит весы (в зависимости от настройки), затем выгружается структура ШК формируемая динамически, название магазина. После этого, в цикле выгружается PLU/сообщение/. В самую последнюю очередь формируются и выгружается экраны (если включено настройкой).

Если в процессе загрузки количество доп. сообщений превысит значение, указанное в настройке «Максимальное количество текстов» то цикл будет продолжен, но доп. сообщения выгружаться НЕ БУДУТ. В логе плагина будет выведено соответствующее предупреждение.

Если в процессе загрузки количество товаров превысит значение, указанное в настройке «Максимальное количество PLU» то цикл будет остановлен, оставшиеся товары НЕ БУДУТ загружены. В логе плагина будет выведено соответствующее предупреждение.

Удаленное управление.

Весы позволяют смотреть и нажимать кнопки на своем экране через любой браузер. Для этого потребуется

1.Включить на весах возможность удаленного управления – в меню 5-3-8-3-2-6 нужно поставить соответствующую галочку.

2.На машине, с которой собираемся управлять весами, необходимо поставить Java. (http://java.com/inc/BrowserRedirect1.jsp?locale=ru)

3.В Панели управления\Программы\Java на вкладке Security нажимаем кнопку "Edit Site List". Добавляем адреса весов, например "http://192.168.0.244". Подтверждаем то, что мы действительно этого хотим.

4.В браузере заходим на весы ("http://192.168.0.244") , вводим имя и пароль (такой же, как и на фтп – bizuser/bizerba), выбираем в меню пункт Remote control (может называться сокращенно, но вполне находимо, тем более что пунктов меню там всего дваJ ) и работаем с весами.

5.


Bizerba KH (На базе WinCE)

Данные весы, с точки зрения настроек аналогичны описанным выше весам KH (на базе Windows PosReady), за исключением форматирования экранов.
Сами клавиатуры (экраны) имеют высоту не 600, а 462 пикселя, при этом полностью свободны для размещения панелей. Т.е. панели по вертикали могут иметь значение не от Y=200, а от Y=0, а максимальное значение Y + Height не должно превышать 462 (см. описание узла Panel, атрибут Y)

В остальном – можно использовать все те же самые xml-настройки он весов KH на базе Windows PosReady.

Внимание, WinCE не понимает некоторые форматы картинок, например png и bmp/32bit. Плагин автоматически сконвертирует картинки товаров, но логотип надо подложить в верном формате, например bmp/24bit.


Плагин Cas

Назначение

Плагин обеспечивает обмен информацией с весами CAS CL5000J .

Размещение

\Services\RunBot.Plugins\Cas.x.x.x.x.7z

Настройка оборудования

Настройка весов осуществляется по документации производителя. Копировать сюда страницы из руководства не имеет смысла.

Для работоспособности весов минимально необходимо:

1.Сбросить настройки к заводским. ( пункт 2.8.8 руководства к весам)

2.Установить дату и время. (2.9.4)
(Протокол не поддерживает синхронизацию времени)

3.Настроить интерфейс TCP (2.11.1)

4.Настроить высоту этикеток (2.8.2). Не забывать менять этот параметр при смене типоразмера этикетки в дальнейшем. (Протокол не поддерживает настройку)

Название магазина, формат штрихкода, номер этикетки задавать на весах не нужно. Отдел используется под номером 1, менять его так же не надо. Все остальное настраивается со стороны Store.

Сами этикетки создаются с помощью программы CL-Works (выложено на фтп). Можно прогружать несколько разных форматов и использовать для разных товаров различные этикетки.

Подсказки по созданию этикеток в дизайнере:
Дополнительный текст будет показываться в поле

"Состав продукта1 : 25"

Название магазина в поле "Магазин : 105"

Плагин прогружать этикетки на весы не умеет (невозможно разобрать формат файлов "*.lfm"), поэтому прогрузка возможна только через CL-Works.

Настройки RunStore
В RunStore, при настройке весов, во вкладке этикетки можно перечислить используемые шаблоны – заполнив поля Код и Примечание. Поле Файл будет проигнорировано.

Название настройки | Описание | Значение по умолчанию
Соединение TCP
IP адрес весов | Реальный IP на котором работают весы | 127.0.0.1
Время ожидания ответа от весов | Время в миллисекундах ожидания получения ответа от весов на каждую команду. | 1000
TCP порт весов | Порт открытый на весах для обмена. | 8111
Весы Aclas
Номер этикетки на весах | Номер шаблона этикетки, по умолчанию устанавливающийся каждому товару. Он может быть переопределен в списке привязанных товаров. Должен быть в диапазоне 51-60. | 51
Тип ШК | Какой шк печатается на этикетке. Варианты: ·EAN-13 ·Interlive 2 of 5 ·Code 128 | EAN-13
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5
Название магазина | Текст для шапки(подвала) этикетки |
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Макс. количество символов в строке названия товара | Максимальное количество символов в строке названия товара | 40


Плагин Digi

Назначение

Плагин обеспечивает обмен информацией с различными весами DIGI.

Поддерживаются серии весов SM100, SM300, SM500, SM5100

Размещение

\Services\RunBot.Plugins\Digi.x.x.x.x.7z


Digi SM100/SM300/SM500

Весы Digi серий 100, 300 и 500 построены на одинаковой логике и процесс их настройки во многом совпадает, однако на разных вариантах могут быть небольшие нюансы. Некоторые из описанных настроек уже могут быть настроены так, как надо, но лучше перепроверить.

Настройка оборудования

1.Заправить весы лентой с этикетками согласно инструкции нанесенной под платформой для взвешивания.

2.Подключить весы к сети Ethernet. Проверить, что зеленый индикатор рядом с разъемом загорелся.

3.Установить IP адрес весов. Для этого

·Перейти в Z – режим - нажать [image] [image] [image] [image] , затем, удерживая [image], набрать 0416. Появится сообщение “IP-адрес весов”. Введите первые три октета адреса: 192168005 и нажмите [image].

·Удерживая [image], набрать 0418. Убедится, что маска сети выставлена как 255255255000. Нажать [image].

·Удерживая [image] набрать 141. Перейти к 135 настройке (набрать 135 и затем [image]). На экране должна появиться надпись "PORT NUMBER". Выставить последний октет IP адреса. Нажать клавишу [image] .

·Перейти к настройке 156 (набрать 156 и затем [image]). Установить параметр в 1 (разрешение печатать картинки). Нажать клавишу

·Перейти к настройке 230 (набрать 230 и затем [image]). Установить параметр в 1 (автопечать этикетки после фиксации веса на платформе). Нажать клавишу

·Для печати этикеток в режиме маркиратора штучных товаров (как на DP-90) - Перейти к настройке 28 (набрать 28 и затем [image] ). Установить параметр в 1. Нажать клавишу [image]. Для обычных весов делать это не надо.

·Нажать кнопку [image]. Весы издадут длинный сигнал, означающий, что флэш-память стерта и начнут записывать туда новые настройки. Если в этот момент выключить весы, то они станут неработоспособными до полного сброса настроек и последующей калибровки! После появления сообщения "выкл. и вкл. весы" – выключите весы (выключателем на нижней поверхности в задней части весов).

4.Произвести частичное обнуление памяти весов. Для этого необходимо включить весы (выключателем питания на нижней поверхности) удерживая кнопки [image] и [протяжка ленты]. На вопрос "Очистить память?" ответить да – кнопка [image]. Через некоторое время весы перезагрузятся. Если этого не сделать – весы не будут пинговаться и не будут печатать этикетки !!!

5.Пропинговать IP адрес весов с любого компьютера в сети – (например ping 192.168.5.160)

6.Настроить время, для этого находясь режиме регистрации нажать [image] [image] [image]. Попадаем в режим программирования PLU. Нажимаем [8] и потом [Х]. Вводим дату и время, подтверждая нажатием на [image] . Для выхода из этого режима нажмите [image] 3 раза.

7.Настроить чувствительность датчика этикеток (без этого может не работать режим маркировки). Находясь в режиме регистрации удерживая кнопку [image] набрать 515. Далее нажать [image] (автонастройка).

8.В случае, если в режиме автоматической печати не печатается этикетка, необходимо провести калибровку датчика. Для этого необходимо перейти в Z-режим, четырежды нажав клавишу [image]. Удерживая клавишу [image] и, набрав 516, переключить весы в режим установки чувствительности датчика конца этикетки. Нажать клавишу протяжки для автокалибровки датчика. Нажать клавишу [image] для сохранения и возврата в Z-режим.

9.Настроить начальную позицию печати и размера этикеток. Для различных этикеток, печатающихся в магазине обычно необходимо сдвинуть начальную позицию немного вниз или вверх. Для этого в режиме регистрации (взвешивания) Удерживая [image] набрать 514. Далее набрать цифровое значение от 0 до 30 (опционально знак "-" для сдвига вниз. В противном случае начало печати сдвинется вверх). Для сохранения нажмите клавишу [image]. Для активации настройки надо два раза(!!!) нажать на [image]. Одновременно с настройкой сдвига произойдет автоматическое определение размеров этикетки. Весы выдадут несколько этикеток, на последней проверить совпадает ли черная шахматная линия реальному началу печати на этикетке (окончанию зоны препринта). Если нет – подогнать значение сдвига вручную меняя значение в ту или другую сторону.

10.Повторить все вышеперечисленные действия для всех весов в магазине.

11.Прогрузите весы настройками и товарами. Проверьте на всех весах появление товара и правильность печати этикеток. Для этого положите на платформу весов какой-нибудь вес и нажмите быструю клавишу товара или набрав номер товара и кнопку [image]. На экране весов должно появиться название товара. Для печати этикетки нажать [image]. При неправильном сдвиге начала печати подогнать ее вручную согласно пункту 7.

12.При неправильной печати или при невозможности соединиться с весами по TCP, необходимо проверить ряд установок по умолчанию. Для этого перейти в режим установок пользователя (удерживая клавишу [image], набрать 141).

Установить значения следующих настроек:

SPEC 000 - 4 (для этого набрать 4 [image]) - формат шк

SPEC 001 - 2 (далее набрать 2 [image] ) - в шк печатать вес

SPEC 022 - 0 (далее набрать 2 2 [image] 0 [image]) - ширина ленты 60 мм

SPEC 024 - 16 (далее набрать [image] 1 6 [image]) - формат этик. по умолчанию

SPEC 026 - 1 (далее набрать [image] 1 [image]) - печатать название магазина

SPEC 028 - 1 (далее набрать 2 8 [image] 1 [image]) - датчик этикетки в режиме расфасовки

SPEC 029 - 0 (далее набрать 0 [image]) - отключить непрерывную печать

SPEC 049 - 2 (далее набрать 4 9 [image] 2 [image] ) - сетевой интерфейс - Ethernet

SPEC 050 - 1 (далее набрать 1 [image]) - режим работы - сервер

SPEC 113 - 1 (далее набрать 1 1 3 [image] 1 [image]) - статус печати логотипа -1

SPEC 134 - 0 (далее набрать 1 3 4 [image] 0 [image]) - запрет соединения с хостом

SPEC 245 - 1 (далее набрать 2 4 5 [image] 1 [image] ) - ??

SPEC 262 - 0 (далее набрать 2 6 2 [image] 0 [image] [image]) - тип печати - этикетка

Нажатие клавиши X после ввода номера – переход к этому номеру SPEC, нажатие клавиши [image] – вводит значение в текущий SPEC, нажатие клавиши [image] – выход из режима c сохранением настроек.

error

ВНИМАНИЕ ! При сохранении настроек весов сначала обнуляется флэш-память настроек, а затем в неё записываются новые настройки. Поэтому, после ввода настроек и нажатия клавиши PLU нужно обязательно дождаться, когда на дисплее весов появятся нули. То есть когда весы начнут взвешивать. Окончание звукового сигнала свидетельствует о том, что память настроек стерта, а не записана. Если выключить весы сразу после окончания звукового сигнала, при следующем включении весы выдадут сообщение об ошибке и нужен будет полный сброс с калибровкой. Будьте внимательны !

Так же может быть полезным:
SPEC 645 и 646 = 1 - отмена минимального веса.

Если все описанное выше не помогает – требуется полный сброс весов. Обратитесь в ЦТО.

Настройки RunStore

Название настройки | Описание | Значение по умолчанию
Соединение TCP
IP весов | IP весов | 127.0.0.1
Время ожидания ответа от весов | Время в миллисекундах ожидания получения ответа от весов на каждую команду. | 10000
Весы DigiSm300B32
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Размер шрифта тестов | Размер шрифта доп. текста на этикетке. Рекомендуется изменять вместе с параметрами "Максимальное количество символов в одной строке доп. текста" и "Максимальное количество строк в доп. тексте" | Шрифт 3
Размер шрифта товаров | Размер шрифта названия товара на этикетке. Рекомендуется изменять вместе с параметрами "Максимальное количество символов в одной строке доп. текста" и "Максимальное количество строк в доп. тексте" | Шрифт 7
Максимальное количество строк | Указывается, сколько строчек текста выводится в поле доп. текста помещается на этикетке.Все что не помещается в указанное количество строк – будет отрезано плагином при подготовке загрузки.Если вы ошибетесь, и строчек получится больше, чем помещается на этикетке – не напечатается весь текст! Если установлен 0 (по умолчанию) – то параметр игнорируется. Весы понимают до 15 строчек. | 0
Количество букв на строку доптекста | Сколько символов влезает в одну строку текстового сообщения на этикетке. В зависимости от дизайна этикетки значение по умолчанию может быть переопределено. Весы крайне негативно относятся к ситуации когда строка не помещается в отведенное ей поле – не печатают ее совсем или не печатают следующую строку! Абсолютный максимум - 54 символа (используется самый маленький шрифт) при ширине поля 580 поинтов (58мм) | 52
Путь до файла со спецтекстами. | Полный путь до файла с текстами этикетки (например слова "Цена", "Вес" и т.п.) доступный с машины, где работает плагин. | Не задан, тексты будут заданы внутренним кодом плагина.
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Название магазина | Текст для шапки(подвала) этикетки |
Макс. количество быстрых клавиш | Количество кнопок на клавиатуре весов, которые способны вызывать печать этикетки на товар. | 32
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5


Digi SM500P подвесные

Настройка осуществляется аналогично весам DIGI SM300 за одним исключением - после настройки первых трех октетов IP адреса и маски подсети весы могут не пустить в меню настроек ( [image] + 141) поэтому может потребоваться их перезагрузка для последующей настройки.


DIGI SM500BS (самообслуживание)

Настройка осуществляется аналогично весам DIGI SM300, но надо иметь ввиду следующее:

1. После настройки первых трех октетов IP адреса и маски подсети весы могут не пустить в меню настроек ( [image] + 141) поэтому может потребоваться их перезагрузка для последующей настройки.

2. Для работы в режиме самообслуживания необходима установка SPEC 300 в значение=1 (в z режиме [image] + 141, 300, [image], 1, [image], [image].

3. Проверить блокировку цифровой клавиатуры. При нажатии на цифровые кнопки в режиме регистрации (взвешивании) весы пискнут и напишут – "режим самообслуживания". Если этого не происходит, а нажатые цифры появляются на экране – делаем следующее:

• Выключаем весы

• Переворачиваем на бок и отвинчиваем снизу два винта кожуха закрывающие материнскую плату. Осторожно (!) отгибаем ее в сторону, чтобы не порвать пломбу которой этот кожух скреплен с корпусом весов.

• В центре (а не сбоку!) платы видим джампер. Переключаем его на другую пару.

• Аккуратно ставим весы на ноги стараясь не оторвать кожух и включаем. После тестирования на экране будет написано "Сервисный режим"

• Заходим в Z – режим - нажать [image] [image] [image] [image], затем, удерживая [image], набрать 142.

• Набрать номер спека 664, [image], 1, [image],

• После сохранения настроек – выключить весы. Установите джампер в исходное состояние. Проверьте, запрещено ли теперь нажатие цифровых клавиш. Выключите весы и закройте кожух.

Особенности работы

Весы DIGI 300/500 для самообслуживания могут иметь разные блоки клавиатур по 48 или 60 клавиш.

Если блоки установлены по 48 клавиш, необходимо учитывать, что адресация у них все равно по 60 клавиш. Из этого делаем вывод, что для программирования товаров для быстрых кнопок мы можем использовать интервалы с 1 до 48 и с 61 по 108. Номера с 49 по 60 будут выгружаться без ошибок, но вызвать такой товар с клавиатуры весов будет невозможно. Последняя кнопка верхней клавиатуры будет вызывать товар 48, а первая кнопка нижней - 61! Например, если Вы назначите товару быструю кнопку №52 то его вызвать с клавиатуры будет невозможно!!!

Данную особенность можно решить только с помощью виртуальных быстрых кнопок.

Для блоков по 60 кнопок, такой проблемы конечно нет.

error

В случае неработоспособности клавиатур, так же стоит проверять спеки 664=1, 672=0 ?, 688 =1


DIGI SM5100

Настройка оборудования

1.Установить IP адрес весов. Для этого :

Перейдите в Z режим: 4 раза нажмите клавишу

Весы должны отобразить “Z 1.0. RESET SALES DAILY”

Удерживая клавишу [image], набрать 0,4,1,6.

Ввести первые три октета IP адреса, например, если IP=192.168.0.222, надо ввести 192.168.0.

Нажать клавишу [image] для сохранения изменений и возврата в исходный режим.

В Z режиме, войдите в режим настроек пользователя:

Удерживая клавишу [image], набрать 1,4,1.

Весы должны отобразить: SP000 ….ITEM BARCODE.

Набрать 1,3,5 и нажать на клавишу [image].

Весы отобразят: SP135….PORT #.

Здесь ввести последний октет IP адреса, например , 222.

Нажать клавишу [image] для перехода к следующей настройке.

Нажать клавишу [image] для сохранения изменений. Для возврата в исходный режим два раза нажать [image] .

ВНИМАНИЕ: Выключать весы, пока идет сохранение настроек нельзя!!!

2.Ввод маски подсети.

Перейдите в Z режим: 4 раза нажмите клавишу

Весы должны отобразить “Z 1.0. RESET SALES DAILY”

Удерживая клавишу [image], набрать 0,4,1,8.

Ввести маску подсети, например 255.255.255.000

Нажать клавишу [image] для сохранения изменений. Для возврата в исходный режим два раза нажать [image].

После ввода параметров TCP IP, выключить и включить весы, проверить наличие связи с весами при помощи команды ping.

Настройки RunStore

Осуществляются аналогично DIGI SM300


DIGI – программирование этикеток для весов

Этикетка для весов настраивается в программе поставщика весов, компании Сервис Плюс - «Label Master», по инструкции входящей в комплект этой программы.

Однако есть замечания, а именно:

- Весы могут адресовать до 8 пользовательских форматов этикеток, несмотря на заявленное количество 99. Номер с 1 до 8 указывается в «свойствах этикетки» - «Номер». Его же надо будет ввести в окне настройки весов – вкладка этикетки – Код.

- Рекомендуем сохранять этикетки в разных файлах, при этом размер файла всегда должен быть строго 2800 байт. С точки зрения весов все форматы этикеток могут размещаться в одном файле, однако, при привязке товаров к форматам в системе Run2010 может получиться путаница.

- Настройку «файл f38» можно и нужно игнорировать, система Run2010 сама выгрузит стандартные текстовые данные для этикетки (вес, сумма, итого и т.д.).

В настройках весов можно указать путь к файлу f38 ("Путь до файла со спецтекстами"). Выгрузка будет происходить вместе с форматом этикетки.


Плагин ScaleFileService

Назначение

Плагин обеспечивает обмен информацией с весами и упаковщиками Digi и Cas (Ishida) через сторонние сервисы, т.е. занимается формированием текстовых файлов для импорта этих сервисов.

Размещение

\Services\RunBot.Plugins\ScaleFileService.x.x.x.x.7z

Настройки RunStore

Для работы с упаковщиками Digi следует выбирать тип устройства - "Сервис QLoad", для работы с Ishida - "Сервис QloadWm-Nano"

Название настройки | Описание | Значение по умолчанию
Qload для упаковщиков DIGI
Путь к папке импорта сервиса | Полный путь к каталогу импорта сервиса, доступный с компьютера, где запущен плагин. |
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5
Тип файла обмена | Варианты: ·Тестовой ·CSV | CSV

Обращаем внимание на то, что операция выгрузки завершается успехом по факту размещения файла экспорта в папке. Разбор ответа сервиса не осуществляется.


Плагин Shtrih

Назначение

Плагин обеспечивает обмен информацией с различными весами Штрих-Принт без использования драйвера производителя весов.

Размещение

\Services\RunBot.Plugins\Shtrih.x.x.x.x.7z

Настройка оборудования

Настройка весов осуществляется по документации производителя.

Вам необходимо настроить IP адрес и структуру базы данных весов, эти данные надо будет использовать в настройках ПО.

Необходимые для настройки пункты в меню весов (все остальное или работает по умолчанию как надо, либо настраивается плагином автоматически):

(1.1.7) Доступ к ПЛУ – устанавливать как нужно для работы магазина, но нужно понимать, что это такое. См. описание настройки Store – «Выгружать в PLU»
(1.4.1) Товары / сообщения – опять же, устанавливать, как считаете нужным, главное запомните значение. И старайтесь настраивать все весы одинаково.

(1.6.1.1) IP адрес - ну тут понятно

(1.6.1.2) UDP порт – можно не менять, по умолчанию 1111. Если меняете - не забудьте поправить эту настройку со стороны RunStore

Настройки RunStore

Название настройки | Описание | Значение по умолчанию
Соединение TCP
IP весов | IP весов | 127.0.0.1
Пароль для связи с весами | Пароль для связи с весами | 30
Время ожидания ответа от весов | Время в миллисекундах ожидания получения ответа от весов на каждую команду. | 10000
UDP порт весов | UDP порт используемый на весах. | 1111
Локальный порт UDP сервера | UDP порт используемый на сервере с плагином для отсылки сообщений на весы. См. примечание после таблицы |
Весы Штрих-Принт
Префикс штрихкодов | Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29 | 28
Версия прошивки весов | Варианты: - 4.5 выпущенная до лета 2015 года - 4.5 выпущенная с лета 2015 до мая 2016 года. Начиная с лета 2015 года, компания Штрих, начала выделять в прошивках весов часть команд, в отдельную, защищенную паролем (ключом) функциональность. Ключ необходимо выкупать за отдельные деньги. В такой прошивке нет возможности убрать с экрана сообщение пользователю. (возвращается ошибка "неправильный пароль). Для обхода такой ситуации добавлена эта настройка. Если выбрать второй вариант, на весах при загрузке НЕ будут показываться сообщения фасовщику, и они не будут соответственно скрываться. Для фасовщика, процедура загрузки весов будет выглядеть как "зависание" весов (при нажатии на любую кнопку на клавиатуре весов будет появляться сообщение – клавиатура заблокирована). Об этом надо помнить. Прошивку с исправленной ошибкой обещали весной 2016, но информации об этом у нас нет. Так же стоит учитывать что перепрошивка весов затруднительна, и производится только в условиях ЦТО. | 4.5 выпущенная до лета 2015 года
Вариант печати изображения на этикетке | Управление печатью изображения на этикетке. -Не печатать на всех этикетках графическое изображение - Печатать на всех этикетках графическое изображение 1 - Печатать на всех этикетках графическое изображение 2 - Использовать привязку к этикеткам См. примечание после таблицы. | Не печатать на всех этикетках графическое изображение
Синхронизировать дату/время каждую прогрузку | Если да, при каждом сеансе связи с весами плагин установит на весы дату и время компьютера. | Да
Бегущая строка | Текст, который будет прокручиваться на дисплее весов. По умолчанию – пустая строка, которая, однако, будет прогружена (затрет существующую). Максимальная длина – 22 символа (лишнее будет отсечено) |
Макс. количество быстрых клавиш | Количество кнопок на клавиатуре весов, которые способны вызывать печать этикетки на товар. | 90
Максимальная длина строки сообщения | Сколько символов влезает в одну строку сообщения. Количество строчек | 50
Макс. количество строк в названии магазина | Сколько строк с названием магазина влезает в этикетку | 2
Макс. количество символов в названии магазина | Сколько символов влезает в поле названия магазина | 30
Очищать ли весы каждую загрузку | Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов. | Да
Название магазина | Текст для шапки(подвала) этикетки |
Максимальная длина кода товара | Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг. | 5

Настройка сетевого соединения.

Данные весы работают по протоколу UDP, а не TCP, как все остальные. В связи с этим в настройках со стороны Store появилась настройка «Локальный порт UDP сервера». Следует понимать, что во время прогрузки одних весов Штрих-Принт, указанный порт будет занят, и если вы захотите использовать плагин в режиме параллельной выгрузки – НЕОБХОДИМО для ВСЕХ весов давать РАЗНЫЕ номера портов СЕРВЕРА! Рекомендуем всегда в пределах одного магазина давать разные порты, даже если не планируется использовать параллельную выгрузку.

Настройка формата этикетки.

В драйвере реализована выгрузка шаблона этикетки, однако у нас нет возможности открыть (разобрать) файл который формирует «Редактор этикеток» от Штриха. Делать собственный редактор тоже не имеет смысла. Однако драйвер позволит вам множить однажды настроенный и отлаженный вариант без использования софта от Штриха. Надо учитывать, что весы могут работать только с одним форматом этикетки. Нельзя добиться печати различных форматов у различных ПЛУ. Ниже описан алгоритм действий для настройки.

1. Рисуем этикетку как хотим.

2. Выгружаем ее на весы под названием "Формат пользователя №1".

3. Запускаем файл ShtrihConfig.exe. Вводим IP адрес весов (порт используется по умолчанию – 1111). Жмем единственную кнопку, и сохраняем где-нибудь xml-файл.
4. В Store, в параметре "Путь до файла с этикеткой" указываем полный сетевой путь до полученного xml-файла. Теперь этикетку можно загружать, нажав в Store кнопку "Этикетки", предварительно выделив нужные весы.

5. Переносим файл по всем магазинам.

ShtrihConfig - отдельная утилита, выкладывается на ФТП, по адресу /Utilities/ShtrihConfig.zip

Настройка печати изображений.

Самый неудачный момент в логике работы весов, но его тоже можно обойти. Скачать изображение с весов нельзя, поэтому предложим несколько готовых вариантов картинок, которые можно поместить в xml файл с параметрами этикетки. Для этого в xml в элемент Parameters необходимо добавить элемент Picture1 и/или Picture2. Содержимое данных элементов будет загружено на весы в качестве изображения 1 или 2. Если имена элементов повторяются, записан на весы будет только один - последний.

В качестве готовых вариантов предлагаем такие изображения:

<!-- EAC 5*5 мм. На черном фоне -->
<Picture1>05050201ffffffffffffffffffffffffffffffe03c00780fe03c00780fe03c00780fe03c00780fe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe03c0078ffe03c0078ff05050202e03c0078ffe03c0078ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe1fc3c78ffe03c3c788fe03c3c780fe03c3c780fe03c3c780fffffffffffffffffffffffffffffffffffffffff</Picture1>

<!-- EAC 5*5 мм. на белом фоне -->
<Picture2>050502010000000000000000000000000000001fc3ff87f01fc3ff87f01fc3ff87f01fc3ff87f01e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001fc3ff87001fc3ff8700050502021fc3ff87001fc3ff87001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001e03c387001fc3c387f01fc3c387f01fc3c387f01fc3c387f00000000000000000000000000000000000000000</Picture2>

<!-- РСТ 7*7мм -->
<Picture1>0707010100000000000000000000000000000000000000000000000000000000000000f000000000007fff8000000003fffff00000003fffffff8000007fffffffc00000fffffffff00001fffffffffc0003fffffffffc0007fffffffffc000ff07ffffffc001fc0070701021ffffffc001f800fff001c001f0007fe0000003e0307f00000003e0f87e00000003e0f83c00000007e1fc3800000007e1fc38007ff807e1f838007ff807e1f878007ff807e18078000fc007e18078000fc007e180f8000fc007e181f8000fc003e1fff800707010300fc003e1fffc00000003e1fffc00000001e1fffe00000001e1ffff00004001e1ffffc001c001f1fffff007c00079ffffffffc0003dffffffffc0003dffffffffc0001fffffffffc00007ffffffff800003fffffffe000001fffffffc0000003fffffc00070701040000007fffe00000000007fc00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</Picture1>

Весы поддерживают две картинки, но печатать на этикетке могут только одну. Какую именно – настраивается параметром "Вариант печати изображения на этикетке". Первые три варианта настройки не нуждаются в комментариях, а последний – "Использовать привязку к этикеткам" рассмотрим поподробнее.

К сожалению, из-за абсолютно различной логики у производителей весового оборудования невозможно добиться унификации настроек. В данном случае, что бы не перегружать интерфейс привязки товаров к весам в Store мы воспользуемся списком форматов этикеток. Поскольку Штрих не может одновременно работать с несколькими этикетками, этот список можно использовать как селектор картинок. Выбираем необходимые весы в Store, кнопка "Привязка товаров", вкладка "Этикетки". Заводим три этикетки с кодами 0, 1 и 2. Что в полях Файл и примечание – не имеет значения. Теперь на уровне весов мы можем привязать эту этикетки к товарам. 0 – не будет печататься картинка, 1 – будет печататься Picture1, 2 – соответственно Picture2.


Плагин MetlerToledo

Назначение

Плагин обеспечивает обмен информацией с весами Metler Toledo.

При выгрузке товара на весы выполняются несколько функций.

1.Всегда и безусловно на весы выгружается формат ШК, автоматически генерируемый исходя из настроек «Префикс ШК» и «Длина кода товара в весовом ШК». Формат всегда выгружается под номером заданный в настройке «Номер формата ШК», именно его надо использовать в шаблоне этикетки!

2.В зависимости от настройки «Синхронизировать время каждую прогрузку» на весы будет передаваться текущее системное время компьютера. По умолчанию значение – да.

3.В зависимости от настройки «Очищать весы перед загрузкой», все ПЛУ на весах будут удалены. Время эта операция почти не занимает. По умолчанию значение – да.

Загрузка форматов этикеток и настроек с помощью плагина не производится!

Размещение

\Services\RunBot.Plugins\MetlerToledo.x.x.x.x.7z

Настройка оборудования

1.Сброс ОЗУ (Если надо, или например при ошибке 200). В весах Mettler Toledo Tiger P/PRO во всех модификациях (8442 -3600, -3610S, -F610 и др.) возможен возврат к заводским настройкам сбросом памяти ОЗУ. Для очистки ОЗУ зайдите в сервисный режим весов. Для этого нажмите клавишу "CODE", а затем на цифровой клавиатуре наберите сервисный пароль 24681357, нажмите клавишу "*" для подтверждения. Выберите курсором 5 пункт "Заводская конфигурация", подтвердите "*". Затем нажмите "1" и еще раз "*". Весы выдадут сообщение "Конфигурация активна". После того, как пропадет сообщение с экрана - сброс ОЗУ произведен.

error

При сбросе ОЗУ сбрасывается содержимое базы данных (артикулы, дополнительные тексты, рекламные тексты, продавцы, группы товаров и т.д.), настройки шаблонов этикеток, настройки режимов работы, сервисные настройки (настройки принтера, сетевые настройки и т.д.). Обнуления весов не влечет за собой калибровку весов, т.к. калибровочные значения сохраняются.

2.Проверить (изменить) и запомнить параметры структуры базы данных весов – количество доступных PLU и доп. текстов. Для того чтобы попасть в это меню, надо нажать CODE ,потом ввести код 55555 на цифровой клавиатуре, затем нажать *. Тут же можно выбрать пункт номер 3 и распечатается вся информация по занятой и свободной памяти.

3.Настроить сетевой адрес, для этого нажать CODE ,потом ввести код 24681357 на цифровой клавиатуре, затем нажать *. Попали в сервис-меню. Далее либо стрелками, либо цифрами выбрать пункт 21 Настройка Сети, затем нажать *. Ввести IP, затем стрелку вниз, ввести маску подсети, затем стрелку вниз несколько раз, оставляя оставшиеся настройки как есть - весы перезапустятся. Проверьте доступность пингом.

Настройка оборудования с помощью ПО производителя

1.Установить программное обеспечение SPCT 2, запустить его.

2.Выбрать меню Весы\Выбор весов. Добавить все весы, присутствующие в магазине.

3.Выбрать меню Конфигурация\Связь. Указать тип связи – Ethernet. Проставить всем весам адреса и по желанию имена.

4. Выбрать меню Весы\Тест Весов. Если весы откликаются – появится галочка рядом с номером весов.

5.Формат ШК не надо, он будет выгружаться при каждой выгрузке (товаров) под номером 1 исходя из настроек указанных в RunStore.

6.Выбрать в меню Конфигурация\Параметры этикетки\ необходимый тип для настройки. Обычно используется весовая этикетка обслуживания или весовая этикетка предупаковки. Их надо настроить обязательно.
В поле "Этикетка №" надо указать номер формата этикетки, который вы создадите/загрузите следующим пунктом(7).
Обязательно заполните все поля "Шрифт…" Без указания размера шрифта весы просто не напечатают указанное поле (!).
Остальные поля заполняются по необходимости. В поле номера рекламного сообщения – надо поставить 1, Store выгружает в него фамилию фасовщика. Нажмите кнопку "PC>Весы". Повторите для остальных типов этикеток.

7.С помощью меню Дизайн этикетки откройте программу VisEdit и откройте/создайте шаблон этикетки.
В качестве номера штрих-кода используйте тот который укажете потом в настройках Store (обычно =1)

Дополнительная информация о работе плагина

·Реальное количество прогружаемых PLU заранее не известно. Если память на весах кончилась в процессе загрузки, весы не станут возвращать ошибку, а просто проигнорируют товары которые «не влезли». Поэтому если в магазине на весах не хватает товара, который по всем признакам должен был быть прогружен – попробуйте почистить список привязанных групп/товаров от ненужных.

·Дополнительные тексты прогружаются по такой же схеме, причем после всех PLU, поэтому шанс их не увидеть на весах – выше.

·Дополнительные тексты не будет выводиться, если не задать шрифт для него (оставить незаполненным поле размера шрифта в SPTC)

·весы Toledo Tiger P не умеют работать с графикой. Логотип магазина следует выносить в шаблон этикетки в типографии. Значок "РСТ" можно добавить в некоторых прошивках с расширенным набором функций ( 360506.0х, 360311.0х ).
Для того, чтобы его напечатать на этикетке нужно в редакторе Visedit указать место его расположения. Для этого создается новое поле Спец.текст, шрифт которого выбран равным 16 ( номер лого Ростеста ), а в свойстве "Строка" записано 2 символа ☼$. Для значка "EAC"- логотипа нет, но его можно написать символами.

·Символ "№" не печатается весами и заменяется при печати текстов запятой.

Настройка работы со свободной ценой.

Есть возможность устанавливать любую цену на товар на самих весах и выводить итоговую сумму в ШК этикетки.

Для включения этой возможности необходимо выполнить ряд операций, а именно:

·В дизайнере этикеток, поменять у шаблона в поле ШК тип ШК с EAN13 на CODE25. Выгрузить этикетку на весы.

·В настройках весов RunStore, отметить параметр "Добавлять цену в ШК"

·На самих весах надо нажать CODE ,потом ввести код 666666 на цифровой клавиатуре, затем нажать *, а потом дважды кнопку ↓. Далее выбираем CODE25 (нажимаем на 5), затем *, и выходим из настроек

Теперь весы всегда будут печатать ШК в формате CODE25. Шаблон ШК формируется плагином по следующему принципу:

2 символа префикс из настройки "Префикс штрихкода"

5 или 6 символов-код товара в зависимости от настройки "Максимальная длина кода"

4 или 5 символов-вес, в обратной зависимости от настройки "Максимальная длина кода". Т.е. если код 5 символов, вес - 5, если же код 6, то вес – 4.

5 символов – сумма товара

Для того что бы оператор на весах мог изменить цену товара, этот товар должен быть добавлен в список разрешённых для этого товаров в офисе. Если товар добавлен – на весах, после вызова товара можно нажать клавишу "#" и ввести новую цену на товар.

Цена товара, распечатанная в ШК, не гарантирует такой же цены на кассе – см. изменения по RunPos!!!

Настройка свободного формата ШК

Есть так же возможность указывать шаблон напрямую, как в программе SPCT.

Если меняется тип шк с EAN13 на любой иной, то необходимо выполнить ряд операций, а именно:

·В дизайнере этикеток, поменять у шаблона в поле ШК тип ШК с EAN13 на CODE25 (или иной). Выгрузить этикетку на весы.

·На самих весах надо нажать CODE ,потом ввести код 666666 на цифровой клавиатуре, затем нажать *, а потом дважды кнопку ↓. Далее выбираем CODE25 (или иной), затем *, и выходим из настроек

Сам формат шк должен быть составлен по следующим правилам (подробнее – в руководстве к весам)

Символ | Кол-во | Описание
A | (1-13) | артикул (товарный код);
B | (4-7) | сумма покупки (произведение цены на массу);
C | (1) | контрольная сумма (в EAN13 может быть и в середине штрих-кода);
D | (6) | текущая дата;
N | (4) | номер чека;
O | (1) | номер оператора;
P | (1-6) | номер PLU;
R | (1,2) | номер тары
S | (1,2) | номер весов в сети;
U | (1-6) | цена товара;
W | (1-4) | номер группы товаров.

Например:

Весовой товар: 28PPPPCQQQQQ

Штучный товар: 20AAAAAAAAAA


Metler Toledo (старая прошивка)

Старой прошивкой мы будем называть прошивку с номером НИЖЕ 360506.

Особенности

Печать доп. текста осуществляется в поле «Название PLU» - это ограничение самих весов и их прошивки.

Настройка RunStore

Название настройки

Описание

Значение по умолчанию

Соединение TCP

IP весов

IP весов

127.0.0.1

Время ожидания ответа от весов

Время в миллисекундах ожидания получения ответа от весов на каждую команду.

10000

Порт

Порт используемый на весах.

3001

Весы Metler Toledo

Префикс штрихкодов

Первые две цифры ШК формируемые весами. Может быть в диапазоне 20-29

28

Использовать ли расширенный шк с ценой

Если да, то формат ШК будет формироваться как Code25 (а не EAN13) и включать в себе сумму покупки. Параметр " Шаблон ШК" при этом будет проигнорирован. См. ниже описание свободной цены.

Нет

Подпись для срока годности

Если срок хранения размещается в отдельном поле, то настройка не имеет смысла.

В иных случаях – настройка будет использоваться для формирования строки срока годности. Например «Годен »

Годен

Где показывать срок хранения.

Варианты размещения информации о сроке годности товара.

·В отдельном поле – Дата показывается в стандартном поле срока годности. Однако в данном поле нельзя указать срок в часах (будет округлено до суток). Поле представляет собой дату, т.е. например "21.10.14"

·В теле доп. сообщения – в начале сообщения отдельной строкой будет добавлена текстовая информация о сроке. Поле представляет собой строку, т.е. например так: "Годен 36 часов" (подпись задается в параметре "Подпись для срока годности")

·Под названием товара

В отдельном поле

Какой номер шаблона ШК использовать

Номер, под которым в весах будет записан формат ШК. Должен совпадать с номером на этикетке.

1

Очищать ли весы каждую загрузку

Если да, то перед загрузкой товара будут очищены таблицы товаров, доп. сообщений и колонтитулов.

Да

Синхронизировать ли время

Если да, при каждом сеансе связи с весами плагин установит на весы дату и время компьютера.

Да

Количество страниц в пакете

Сколько записей уходит на весы в одном пакете. Не стоит менять без причины.

10

Имя упаковщика

Строка с фамилией упаковщика.

Название магазина

Текст для шапки(подвала) этикетки

Максимальная длина строки дополнительного текста

Размер поля доп. текста на весах. На деле всегда = 200

200

Максимальная длина строки наименования товара

Сколько символов допустимо выделять для названия товара. Если больше 60 – будет ошибка.

Максимальное смещение срока хранения в днях

При превышении этого параметра срок годности будет браться равным этому параметру

498

Макс. количество быстрых клавиш

Количество кнопок на клавиатуре весов, которые способны вызывать печать этикетки на товар.

154

Максимальное количество спецтекстов

Заполните исходя из структуры БД весов(см. пункт 2 настройки весов). В случае превышения параметра со стороны RunStore над реальным, ошибки не произойдет, но текстов на весах будет меньше, чем вы рассчитываете.

2000

Максимальное количество PLU на весах

Заполните исходя из структуры БД весов(см. пункт 2 настройки весов). В случае превышения параметра со стороны Store над реальным, ошибки не произойдет, но товаров на весах будет меньше, чем вы рассчитываете.

4000

Шаблон штрихкода

Шаблон штрихкода сформированный по правилам производителя весов. Описан ниже. Если шаблон задан, то игнорируются параметры: Префикс штрихкода, Максимальная длина кода.

Данная опция игнорируется если включена опция " Добавлять цену в ШК"

Не рекомендуется менять без необходимости.

Максимальная длина кода товара

Сколько символов отводить в ШК на код товара. Возможны значения 5 и 6. Если отведенных символов не хватит - возможна аварийная остановка загрузки, ошибки на весах при печати этикеток. Если использовать 6 символов, то мы ограничиваем кодирование веса 4мя символами, т.е. максимум 9.998кг.

5


Metler Toledo (премиумная прошивка)

Премиумной прошивкой мы будем называть номер 360506 (и возможно выше).

Единственное отличие реализации драйвера для стандартной прошивки и премиумной - в расширении количества символов в доп. тексте. В стандартной - это количество ограничено 200 символами. В премиумной – теоретически не ограничено, за счет возможности печати нескольких доп. текстов в одной этикетке.

Настройка RunStore

Все настройки производятся так же, как и у Mettler Toledo Tiger со старой прошивкой

Дополнительные параметры:

Название настройки | Описание | Значение по умолчанию
Весы Metler Toledo
Максимальное количество специальных текстов в одной этикетке | Количество доп. текстов допустимых в одной этикетке. Для значения 3 означает, что общее количество символов в доп. тексте будет равно (2*194)+200=588 символа. (194 символа в сообщении вместо 200 обусловлены изменением формата передачи данных). | 3
Вынесение текста в отдельное поле. | Разделять или нет на этикетке поля названия товара и доп. текста. Включение этой настройки дополнительно «отъедает» по два символа от каждого текста. Например для следующего примера (3 доп. текста на этикетку) получится так: (2*192)+198=582 символа. Так же, включение потребует изменения шаблона этикетки. | Нет
Управление различными форматами этикетками через номер НДС | См. ниже про привязку формата этикетки к товару | Нет

Привязку формата этикетки к товару

Для весов с премиумной прошивкой (360506.0х) есть возможность привязывать формат этикетки к товару. Для этого на весах необходимо выбрать логику обработки поля НДС – нажимаем CODE 666666 *, переходим к 27 пункту, и выбираем в нем – формат этикетки. Жмем CODE для сохранения. Далее выгружаем на весы необходимые шаблоны этикеток, например без логотипа и с логотипом под разными номерами. Далее, в RunStore в окне привязки товаров, во вкладке Этикетки заводим номера выгруженных этикеток и их описание. Путь до файла выкладывать не надо, т.к. плагин не умеет выгружать сами форматы на весы. Теперь во вкладке товаров можно привязать конкретную этикетку к каждому товару. Если ничего не указано – то по умолчанию будет использован тот номер этикетки, который в настройках spct указан для данного типа обслуживания. Теперь можно выгружать товар, в поле НДС теперь подставляется номер этикетки, а весы такой НДС правильным образом понимают (костылище жуткий, но работает…).


Виртуальные быстрые клавиши (ВБК)

Виртуальные быстрые кнопки (ВБК) созданы для переназначения БК со стороны Store. Используя ВБК можно назначать вызов одного товара на несколько БК (создав одну большую кнопку для товара).

Для того чтобы воспользоваться данной функцией, необходимо в настройках весов (Store) установить галочку – "Использовать виртуальные быстрые кнопки ". После сохранения настроек, в окне привязок товаров к весам появится новая вкладка – "Виртуальные быстрые клавиши". В нем необходимо задать соответствие ВБК и реально существующей на клавиатуре БК.

Рассмотрим работу на примере весов DIGI SM-300. Клавиатура этих весов выглядит так:

Например, мы хотим для удобства покупателей сделать большие клавиши. Для этого прописываем такие соответствия (для 1ой клавиши):

ВБК | БК
1 | 25
1 | 26
1 | 27
1 | 28
1 | 17
1 | 18
1 | 19
1 | 20

Теперь клавиатура будет выглядеть так (красным цветом отмечена ВБК):

Для того чтобы привязать товар к ВБК надо действовать абсолютно точно так же, как и с БК – во вкладке привязки товаров установить номер БК=ВБК (в данном примере -1). Надо учитывать, что после включения галочки "Использовать виртуальные быстрые кнопки" на весы НЕ БУДУТ выгружаться привязки к отсутствующим в таблице соответствия ВБК. Для текущего примера – выгружена будет только привязка товара к ВБК=1, остальные будут проигнорированы.


Полезные советы

А точнее - совет, к которому не прислушиваются :)

По возможности старайтесь размещать штрих-код на этикетке вертикально, цифрами к центру, а не горизонтально как по умолчанию предлагают все редакторы. При вертикальном расположении частичное загрязнение печатающей головки не приводит к проблемам чтения кода сканером на кассе. Так же, при сдвиге печати в сторону (при неправильной установке ленты) потеря части шк опять же, никак не сказывается на чтении. К сожалению, не все весы справляются с этой задачей.


Ограничения

Весы | Полная очистка | Загрузка форматов этикеток | Виртуальные БК
Digi | + | + | +
Toledo | + | - | +
Cas | + | - | +
Штрих-Принт | + | - | +
Aclas 215 | + | + | +
Aclas R1 | - | + | -
Bizerba | + | - | +
Cas (direct) | + | - | +


Navigation: Плагины > Оборудование >

Return to chapter overview

Инфокиоски


Плагин Shuttle

Назначение

Плагин обеспечивает работу прайсчекеров Shuttle SG-15. Плагин выступает в качестве сервера, к которому, по факту считывания ШК обращаются инфокиоски. Плагин получив считанный на киоске штрихкод, запрашивает хранимую процедуру в базе данных RunStore, ожидает ответа, и полученную информацию по товару отправляет ожидающему ответа инфокиоску.

Размещение

\Services\RunBot.Plugins\Shuttle.x.x.x.x.7z

Особенности работы.

Прайсчекер сам устанавливает соединение с сервером (плагином) каждые 20 секунд. Запрос ШК со стороны прайсчекера НЕ устанавливает соединение. В процессе проверки надо учитывать, что после включения устройства (или плагина)– в течение этих 20 секунд запросы по шк могут заканчиваться ошибкой. Когда прайсчекер устанавливает связь с сервером – мигающая надпись "Отключено" исчезает.

Настройка оборудования.
Настройка осуществляется с помощью утилиты SG15Config.exe распространяемой вместе с устройством. Для устройства необходимо задать IP адрес, режим работы - "клиент", установить IP адрес сервера, на котором работает плагин и порт на сервере (по умолчанию 30576). При желании можно изменить системные сообщения устройства и таймауты отображения сообщений. Кодовая страница должна быть установлена в 1251.

Настройка плагина.

Название настройки | Описание | Значение по умолчанию
ServerName | Имя сервера SQL (инстанса) | ""
IntegratedSecurity | Интегрированная безопасность | "Sql"
MasterLogin | Логин к базе SQL | "sa"
MasterPassword | Пароль к базе SQL | ""
ConnectionProtocol | Протокол для подключения | "Default"
Timeout | Таймаут SQL запросов в секундах | 15
ConnectionTimeout | Таймаут подключения к SQL серверу в секундах | 15
DivisionGuid | Идентификатор подразделения. Необходимо указывать если на сервере обслуживаются более одного подразделения. В противном случае – можно оставить пустым по умолчанию. Однако в целях ускорения желательно этот гуид указывать всегда. | ""
LocalPort | Порт на сервере к которому подключаются прайсчекеры. Необходимо использовать тот порт, который настроен на устройстве | "30576"
TextNotFound | Сообщение, которое показывается покупателю если товар не найден | Товар не найден! Сообщите персоналу магазина!
TextError | Сообщение, которое показывается покупателю если произошла ошибка во время запроса информации по товару | Ошибка системы! Сообщите персоналу магазина!


Navigation: Плагины > Оборудование >

Return to chapter overview

ТСД


Плагин Mobile2015

Назначение

Плагин обеспечивает работу терминалов сбора данных под управлением программы RunMobile2015

Размещение

\Services\RunBot.Plugins\Mobile2015.x.x.x.x.7z

Настройка оборудования

См. документ - "RunMobile2015 руководство администратора"

Настройка плагина.

Название параметра | Описание | Значение по умолчанию
Сервер Mobile2015
Конфигурация сервера | Не меняем |
Ip адрес сервера | Ip адрес, на котором должен работать сервер Mobile2015. Например 192.168.0.200 | 127.0.0.1
Порт файлового сервера | Порт, который будет открыт для обмена данными с тсд | 8751
Каталог с обновлениями для мобильного приложения | Путь задается относительно каталога работающего плагина. | Updates
Период проверки наличия новых обновлений | Плагин с указанным интервалом проверяет папку, указанную в настройке "Каталог с обновлениями для мобильного приложения", и в случае нахождения - уведомляет тсд по мере их подключения. | 00:30:00
Настройка логирования
Уровень логирования | Уровень детализации журнала лога. Самая детальная - "трассировка", самая минималистичная - "фатальные ошибки". В повседневной работе достаточно уровня "Информация", для разбора каких либо ошибок, желательно иметь журнал с уровнем "трассировка". | Информация
Mongo Database*
Ip адрес mongo сервера | Адрес сервера Mongo | 127.0.0.1
Порт | Порт сервера Mongo | 27017
Название базы данных | Название базы данных, будет создана, если не существует. | runpos
Название коллекции отложенных чеков | Название коллекции отчетов, будет создана, если не существует. | parkedCheques
Настройки доступа к Sql-серверу
Логин | Логин пользователя БД SQL Server | sa
Пароль | Пароль пользователя БД SQL Server |
База данных, к которой подключаться по умолчанию | База данных БД SQL Server, к которой подключаться по умолчанию | master
Протокол для подключения | Протокол, по которому работаем с БД SQL Server | Default
Таймаут SQL запросов | Таймаут SQL запросов к БД | 00:03:00

* -БД Mongo используется только для работы QBuster, вместе с кассами для хранения отложенных чеков. Если QBuster не планируется к использованию, настройки этого блока можно игнорировать.


Navigation: Плагины >

Return to chapter overview

Общие


Плагин для выполнения произвольных заданий согласно расписанию

Назначение

Плагин предназначен для запуска произвольных заданий на SQL-сервере по расписанию, с возвращением ответа по почте и/или с уведомлением в интерфейсе RunStore. Подробнее см. следующую главу.

Размещение

\Services\RunBot.Plugins\SqlAgent.x.x.x.x.7z

Принцип работы

В офисе, в приложении rrMain формируются задания, в виде sql-скриптов, на них устанавливаются расписание, после чего задание передается в подразделение с помощью файлов типа "AGN". В подразделении (RunStore), необходимо принять данный файл (так же, как справочники - "обмен данными"), плагин получив задание, выполняет его согласно расписанию. Если задание было выполнено без ошибок, выполняется уведомление получателей, если с ошибками - отсылается письмо с описанием ошибки.

Настройка плагина.

Название параметра | Описание | Значение по умолчанию
Настройка логирования
Уровень логирования | Уровень детализации журнала лога. Самая детальная - "трассировка", самая минималистичная - "фатальные ошибки". В повседневной работе достаточно уровня "Информация", для разбора каких либо ошибок, желательно иметь журнал с уровнем "трассировка". | Информация
Настройки доступа к Sql-серверу
Имя сервера | Имя сервера, на котором будут выполняться присланные скрипты |
Проверка подлинности | Тип аутентификации на сервере | SQL Server
Логин | Логин пользователя БД SQL Server | sa
Пароль | Пароль пользователя БД SQL Server |
База данных, к которой подключаться по умолчанию | База данных БД SQL Server, к которой подключаться по умолчанию | master
Сетевой протокол | Протокол, по которому работаем с БД SQL Server | Default
Время ожидания соединения | Таймаут подключения к БД | 15 сек.
Время ожидания выполнения | Таймаут SQL запросов к БД | 180 сек
Подразделение
Код репликации подразделения | Код репликации подразделения (ReplCode) из таблицы rrMasterData.dbo.DivisionAddParam (Можно посмотреть в мастерданных - контрагенты - код репликации. Например "101"). Если RunBot обслуживает несколько подразделений, необходимо установить несколько плагинов и настроить каждый из них на одно из подразделений |


Задания для подразделений

Доступно

Оборудование > Задания для подразделений

Назначение

Данный функционал предназначен для планирования запуска на серверах подразделений скриптов (sql), с получением уведомления на указанную электронную почту, а так же в интерфейсе программы RunStore (в виде всплывающих сообщений).

Требования

·В подразделении должен быть установлен работающий плагин SQL Agent

·Возвращаемое скриптом значение должно быть "валидацией" в понятиях системы RunRetail. В качестве примера, в базе данных создана тестовая процедура rrReport.dbo.AgentTestExec, ее следует брать за основу. Это процедура, при запуске вернет сообщение "ТЕСТОВОЕ СООБЩЕНИЕ ТЕСТОВОЕ....." с указанным уровнем валидации (info,warning,error). Если будет указан уровень "except"- будет сгенерировано исключение.

Создание задания

Откроем окно заданий - Оборудование > Задания для подразделений

Нажмем создать.

Заполним название и поле sqlExec. Для тестового задания, это будет выглядеть так:

exec rrReport.[dbo].[AgentTestExec] 'info,warning'

На вкладке "Подразделения" добавьте все магазины/склады, в которых будет выполняться это задание.

На вкладке "Расписание" задайте повторяемость заданий. Вариантов может быть три

·Один раз без расписания - задание будет выполнено как только плагин SQLAgent его получит

·Один раз - однократное выполнение , с указанием даты и времени запуска.

·Повторяющееся значение - полная настройка расписание как часто запускать задачу, в каком интервале времени.

Вкладка "Оповещение" отвечает за то, какие сообщения кому будут показываться.
Непредвиденные ошибки - обработка любых ситуаций, при которых исполнение скрипта не вернула корректный результат валидации.

Валидация - соответственно кому и как будет показан результат выполнения скрипта закончившийся без ошибок.

Оповестить по Email - отвечает за формирование почтовых сообщений.

Оповестить по multicast message - отвечает за появление всплывающих сообщений внизу справа экрана. На данный момент работает только в модуле RunStore.

Поле "Email" можно заполнять несколькими адресами, через запятую.

Поле "теги multicast message" можно назначать следующим образом:
runstore -всплывающее сообщение получат все пользователи модуля RunStore подключенного к серверу, на котором плагин выполнил скрипт.

division{ReplCode}, где ReplCode - код репликации подразделения (ReplCode) из таблицы rrMasterData.dbo.DivisionAddParam (Можно посмотреть в мастерданных - контрагенты - код репликации. Например "101". В таком случае всплывающее сообщение получит только тот RunStore, который подключен к серверу, на котором плагин выполнил скрипт и с активным подразделением равным ReplCode.

Во вкладке "Валидация" можно указать порог уровня валидации для получателя. Например, для "Оповестить по multicast message" можно установить уровень "Информация", а для "Оповестить по multicast message" - "ошибка". Это означает, что, оператор модуля будет получать все сообщения выполнения скрипта, а сотрудники перечисленные в поле Email - только ошибки выполнения этого скрипта.

После сохранения задания, не забудьте отправить их в подразделения (Обмен >SQL Agent > Отправить). Будут сформированы файлы типа "AGN" для транспортировки.

В дальнейшем после удаления или изменения заданий так же необходимо отправить эти задания для обновления информации в подразделениях.


Web-сервер

RunBot имеет встроенный web-сервер. Он поднимается на порту, который указывается в настройках. По умолчанию адрес - http://localhost:8081

Через этот интерфейс некоторые плагины могут показывать подробную информацию о своей работе. На данный момент это все плагины отвечающие за работу с весами, а так же плагины работающие с фтп (в стадии тестирования).

При открытии главной страницы выберите интересующую группу плагинов и временной интервал. Возможность хранения информации и ее длительность зависит от настроек самого плагина.

RSS-рассылки позволяют вам при необходимости подписаться на извещения о событиях генерируемых плагинами. Список доступных рассылок откроется по соответствующей ссылке на главной странице.

Плагины работающие с весами

Накапливается информация по каждому загруженному на весы товару, дополнительному тексту. Информация выводится в том виде, в котором отправлена на весы, а не полученном из базы данных. Т.е. могут быть замены спецсимволов, замена/вставка переносов строк, отрезка лишних символов в длинных строках и т.п. Гарантируется, что то что вы видите на экране БЫЛО отправлено на весы. В логах подобная информация не отражается, для диагностики проблем с загрузкой какого то конкретного товара лучше начинать именно с этого отчета.


Одновременная работа вместе с DeviceService

Допускается одновременная работа RunBot и DeviceService(DS) со следующими условиями и ограничениями:

·Одна касса может управляться либо RunBot, либо DeviceService.

·Допускается ситуация, когда одна касса управляется RunBot, а вторая DS. Однако так делать не рекомендуется.

·Все весы должны управляться либо RunBot, либо DS. Частично это сделать нельзя.

·ТСД так же должны управляться либо RunBot, либо DS. Частично это сделать нельзя.

error

Кассы RunPos с версией 2.36.x.x и ниже могут работать ТОЛЬКО через DeviceService, c версией 2.37.x.x и выше - только через RunBot.

Переподключение кассы с DS на RunBot.

Необходимо в RunStore, в окне "Управление" - "Настройки касс" удалить старую кассу, и добавить новую согласно текущей инструкции.

error

Перед переподключением закройте смены на кассах!

Переподключение весов

Необходимо в конфигурационном файле DS установить настройку "LoadToScaleEnabled" в False и перезапустить DS. Затем, в rrSettings изменить настройку "7013 Настройки весов для сервиса": на RunBot. В RunStore удалить или отключить все весы, и добавить новые согласно этой инструкции.

Переподключение ТСД

Необходимо в конфигурационном файле DS установить настройку "Mobile2012ServerEnabled" в False. В файле DeviceService\Plugins\Mobile2015\Mobile2015.Plugin.dll.config установите настройку IsEnabled в False. Перезапустите DS.


Плагин Shuttle

Назначение

Плагин обеспечивает работу прайсчекеров Shuttle SG-15. Плагин выступает в качестве сервера, к которому, по факту считывания ШК обращаются инфокиоски. Плагин получив штрихкод, запрашивает базу данных RunStore, и полученную информацию по товару отправляет ожидающему ответа инфокиоску.

Особенности работы.

Прайсчекер сам устанавливает соединение с сервером (плагином) каждые 20 секунд. Запрос ШК со стороны прайсчекера НЕ устанавливает соединение. В процессе проверки надо учитывать, что после включения устройства (или плагина)– в течение этих 20 секунд запросы по шк могут заканчиваться ошибкой. Когда прайсчекер устанавливает связь с сервером – мигающая надпись "Отключено" исчезает.

Настройка оборудования.

Настройка осуществляется с помощью утилиты SG15Config.exe распространяемой вместе с устройством. Для устройства необходимо задать IP адрес, режим работы - "клиент", установить IP адрес сервера, на котором работает плагин и порт на сервере (по умолчанию 30576). При желании можно изменить системные сообщения устройства и таймауты отображения сообщений. Кодовая страница должна быть установлена в 1251.

Настройка плагина.

Название настройки | Описание | Значение по умолчанию
ServerName | Имя сервера SQL (инстанса) | ""
IntegratedSecurity | Интегрированная безопасность | "Sql"
MasterLogin | Логин к базе SQL | "sa"
MasterPassword | Пароль к базе SQL | ""
ConnectionProtocol | Протокол для подключения | "Default"
Timeout | Таймаут SQL запросов в секундах | 15
ConnectionTimeout | Таймаут подключения к SQL серверу в секундах | 15
DivisionGuid | Идентификатор подразделения. Необходимо указывать если на сервере обслуживаются более одного подразделения. В противном случае – можно оставить пустым по умолчанию. Однако в целях ускорения желательно этот гуид указывать всегда. | ""
LocalPort | Порт на сервере к которому подключаются прайсчекеры. Необходимо использовать тот порт, который настроен на устройстве | "30576"
TextNotFound | Сообщение, которое показывается покупателю если товар не найден | Товар не найден! Сообщите персоналу магазина!
TextError | Сообщение, которое показывается покупателю если произошла ошибка во время запроса информации по товару | Ошибка системы! Сообщите персоналу магазина!


Шпаргалка

RunBot

установите RunBot

положите нужные плагины в папку с \runbot\repository (для кассы требуется RunPosServer)

установите плагин

перейдите в настройки плагина и установите Ip адрес сервера (компьютер на котором установлен RunBot)

в разделе Mongo Database укажите IP адрес компьютера на котором установлена база Mongo

запустите плагин

RunPos 2.37.*

на кассе, в config.ini требуется добавить секцию:

[NETWORK]

MulticastAddress = 239.0.0.232

MulticastListenPort = 1941

MulticastOutPort = 1945

LocalServerAddress = "адрес где установлен RunBot"

LocalServerPort = 9997

RunStore

в модуле магазина добавить кассовый сервер (Управление - Настройки Кассовых Серверов)

в строке <endpoint address="net.tcp://127.0.0.1:8756/run-retail/RunPosService/Transport/", где вместо 127.0.0.1 ввести IP адрес на котором работает RunBot

нажать кнопку "Проверить", удостовериться что связь установлена.

добавить новую кассу (Управление - Настройки касс - Добавить - Касса RunRetail (WCF) - выберите созданный ранее кассовый сервер - проверьте соединение с кассовым сервером и кассой

добавить пароли пользователей для нового типа касс (Персонал - Кассиры - Изменить. Установить галки в строке " Касса RunRetail POS (WCF)", прогрузить данные операторов на кассы, стандартным способом, кнопка "В кассы" .)


Navigation: »No topics above this level«

Return to chapter overview

Весы

Enter topic text here.


Navigation: »No topics above this level«

Return to chapter overview

Инфокиоски


Navigation: »No topics above this level«

Return to chapter overview

EDI

Enter topic text here.